Commit Message
Comments
Catonano (2016-05-29 18:53 +0300) wrote:
> From 89849ff33cd67243d691748f77f13474676d5361 Mon Sep 17 00:00:00 2001
> From: humanitiesNerd <catonano@gmail.com>
> Date: Fri, 27 May 2016 10:01:59 +0200
> Subject: gnu: Add emacs-queue.
>
> * gnu/packages/emacs.scm (emacs-queue): New variable.
> ---
> diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
> index 5d6db5a..90f55ea 100644
> --- a/gnu/packages/emacs.scm
> +++ b/gnu/packages/emacs.scm
> @@ -1706,3 +1706,24 @@ It is recommended to use @code{clojure-mode} with paredit or smartparens.")
> The purpose of this library is to wrap all the quirks and hassle of
> @code{package.el} into a sane API.")
> (license license:gpl3+)))
> +
> +(define-public emacs-queue
> + (package
> + (name "emacs-queue")
> + (version "0.1.1")
> + (source
> + (origin
> + (method uncompressed-file-fetch)
> + (uri (string-append "http://elpa.gnu.org/packages/queue-" version ".el"))
> + (sha256
> + (base32
> + "0jw24fxqnf9qcaf2nh09cnds1kqfk7hal35dw83x1ari95say391"))))
> + (build-system emacs-build-system)
> + (home-page "http://www.dr-qubit.org/emacs.php")
This page tells it moved to
<http://www.dr-qubit.org/tags/computing-code-emacs.html>
so I changed it.
> + (synopsis "Queue data structure")
I made it: "Queue data structure for Emacs"
> + (description
> + "These queues can be used both as a first-in last-out (FILO) and as a
I added here:
This Emacs library provides queue data structure. These queues ...
> +first-in first-out (FIFO) stack, i.e. elements can be added to the front or
> +back of the queue, and can be removed from the front. (This type of data
> +structure is sometimes called an \"output-restricted deque\")")
> + (license license:gpl3+)))
Applied, thanks!
From 89849ff33cd67243d691748f77f13474676d5361 Mon Sep 17 00:00:00 2001
From: humanitiesNerd <catonano@gmail.com>
Date: Fri, 27 May 2016 10:01:59 +0200
Subject: gnu: Add emacs-queue.
* gnu/packages/emacs.scm (emacs-queue): New variable.
---
@@ -1706,3 +1706,24 @@ It is recommended to use @code{clojure-mode} with paredit or smartparens.")
The purpose of this library is to wrap all the quirks and hassle of
@code{package.el} into a sane API.")
(license license:gpl3+)))
+
+(define-public emacs-queue
+ (package
+ (name "emacs-queue")
+ (version "0.1.1")
+ (source
+ (origin
+ (method uncompressed-file-fetch)
+ (uri (string-append "http://elpa.gnu.org/packages/queue-" version ".el"))
+ (sha256
+ (base32
+ "0jw24fxqnf9qcaf2nh09cnds1kqfk7hal35dw83x1ari95say391"))))
+ (build-system emacs-build-system)
+ (home-page "http://www.dr-qubit.org/emacs.php")
+ (synopsis "Queue data structure")
+ (description
+ "These queues can be used both as a first-in last-out (FILO) and as a
+first-in first-out (FIFO) stack, i.e. elements can be added to the front or
+back of the queue, and can be removed from the front. (This type of data
+structure is sometimes called an \"output-restricted deque\")")
+ (license license:gpl3+)))
--
2.5.5