[2/4] emacs-pkg-info

Message ID CAJ98PDxF9qxbw459ozuCbYygrpZ+q8D4igwtW5BcFCDdHN+5BA@mail.gmail.com
State New
Headers

Commit Message

Catonano May 29, 2016, 3:53 p.m. UTC
  
  

Comments

Alex Kost May 30, 2016, 10:13 a.m. UTC | #1
Catonano (2016-05-29 18:53 +0300) wrote:

> From 6b4542d9f52b8f91375d07bd41bcc196a1c0515a Mon Sep 17 00:00:00 2001
> From: humanitiesNerd <catonano@gmail.com>
> Date: Sun, 29 May 2016 10:23:00 +0200
> Subject: gnu: Add emacs-pkg-info.
>
> * gnu/packages/emacs.scm (emacs-pkg-info).

Almost, but not quite ;-)  should be:

* gnu/packages/emacs.scm (emacs-pkg-info): New variable.

> ---
> diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
> index 90f55ea..92ad434 100644
> --- a/gnu/packages/emacs.scm
> +++ b/gnu/packages/emacs.scm
> @@ -1727,3 +1727,25 @@ first-in first-out (FIFO) stack, i.e. elements can be added to the front or
>  back of the queue, and can be removed from the front. (This type of data
>  structure is sometimes called an \"output-restricted deque\")")
>      (license license:gpl3+)))
> +
> +(define-public emacs-pkg-info
> +  (package
> +    (name "emacs-pkg-info")
> +    (version "0.6")
> +    (source
> +     (origin
> +       (method url-fetch)
> +       (uri (string-append
> +             "https://github.com/lunaryorn/pkg-info.el/archive/"
> +             version ".tar.gz"))
> +       (file-name (string-append name "-" version ".tar.gz"))
> +       (sha256
> +        (base32
> +          "1gy1jks5mmm02gg1c8gcyr4f8a9s5ggzhk56gv33b9mzjqzi5rd5"))))
> +    (build-system emacs-build-system)
> +    (propagated-inputs `(("emacs-epl" ,emacs-epl)))
> +    (home-page "https://github.com/lunaryorn/pkg-info.el")
> +    (synopsis "Information about packages")

I wrote: "Information about Emacs packages".

> +    (description
> +     "This library extracts information from installed packages.")

and: "This library extracts information from installed Emacs packages."

I made similar modifications (to mention "Emacs") in
synopses/descriptions for other packages, and committed all your
patches, thanks!
  

Patch

From 6b4542d9f52b8f91375d07bd41bcc196a1c0515a Mon Sep 17 00:00:00 2001
From: humanitiesNerd <catonano@gmail.com>
Date: Sun, 29 May 2016 10:23:00 +0200
Subject: gnu: Add emacs-pkg-info.

* gnu/packages/emacs.scm (emacs-pkg-info).
---
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 90f55ea..92ad434 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -1727,3 +1727,25 @@  first-in first-out (FIFO) stack, i.e. elements can be added to the front or
 back of the queue, and can be removed from the front. (This type of data
 structure is sometimes called an \"output-restricted deque\")")
     (license license:gpl3+)))
+
+(define-public emacs-pkg-info
+  (package
+    (name "emacs-pkg-info")
+    (version "0.6")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://github.com/lunaryorn/pkg-info.el/archive/"
+             version ".tar.gz"))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+          "1gy1jks5mmm02gg1c8gcyr4f8a9s5ggzhk56gv33b9mzjqzi5rd5"))))
+    (build-system emacs-build-system)
+    (propagated-inputs `(("emacs-epl" ,emacs-epl)))
+    (home-page "https://github.com/lunaryorn/pkg-info.el")
+    (synopsis "Information about packages")
+    (description
+     "This library extracts information from installed packages.")
+    (license license:gpl3+)))
-- 
2.5.5