Add python-pythondialog

Message ID CAEwRq=oFuyTN=RNU-7ymh=m3m0CwNuzLinM9rGzzjzWUdEqijg@mail.gmail.com
State Superseded, archived
Headers

Commit Message

Vincent Legoll July 27, 2016, 12:30 p.m. UTC
  >> If we inherit, we should let python2- inherit from python3.
>>
>> I was not sure about the right way to process with this, so it
>> ended up in 2 packages.
>
> There has been no update on this for 3 weeks.
> Could someone look into this and reply?

Is that what you want ?
This is still untested though, but I'll try the 2 packages
  

Comments

non such July 28, 2016, 9:34 a.m. UTC | #1
Hi,

thanks for working on this.

Vincent Legoll <vincent.legoll@gmail.com> writes:

>>> If we inherit, we should let python2- inherit from python3.
>>>
>>> I was not sure about the right way to process with this, so it
>>> ended up in 2 packages.
>>
>> There has been no update on this for 3 weeks.
>> Could someone look into this and reply?
>
> Is that what you want ?
> This is still untested though, but I'll try the 2 packages

I don't understand. Is this completely untested or have you tested this
before sending the patch?

> -- 
> Vincent Legoll
> From 8b6becfd95235e1559cdb4a3760c5928d707e6cf Mon Sep 17 00:00:00 2001
> From: Vincent Legoll <vincent.legoll@idgrilles.fr>
> Date: Wed, 27 Jul 2016 14:28:06 +0200
> Subject: [PATCH] Add python-pythondialog
>
> Signed-off-by: Vincent Legoll <vincent.legoll@idgrilles.fr>
> ---
>  gnu/packages/python.scm | 21 ++++++++++++++++-----
>  1 file changed, 16 insertions(+), 5 deletions(-)
>
> diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
> index 80ff81f..533d731 100644
> --- a/gnu/packages/python.scm
> +++ b/gnu/packages/python.scm
> @@ -6654,17 +6654,17 @@ facilities for defining, registering and looking up components.")
>  (define-public python2-zope-component
>    (package-with-python2 python-zope-component))
>  
> -(define-public python2-pythondialog
> +(define-public python-pythondialog
>    (package
> -    (name "python2-pythondialog")
> +    (name "python-pythondialog")
>      (version "3.4.0")
>      (source
>       (origin
>         (method url-fetch)
> -       (uri (pypi-uri "python2-pythondialog" version))
> +       (uri (pypi-uri "pythondialog" version))
>         (sha256
>          (base32
> -         "0d8k7lxk50imdyx85lv8j98i4c93a71iwpapnl1506rpkbm9qvd9"))))
> +         "1728ghsran47jczn9bhlnkvk5bvqmmbihabgif5h705b84r1272c"))))
>      (build-system python-build-system)
>      (arguments
>       `(#:phases
> @@ -6678,7 +6678,6 @@ facilities for defining, registering and looking up components.")
>                   (("os.getenv\\(\"PATH\", \":/bin:/usr/bin\"\\)")
>                    (string-append "os.getenv(\"PATH\")  + \":" dialog "/bin\"")))
>                 #t))))
> -       #:python ,python-2
>         #:tests? #f)) ; no test suite
>      (propagated-inputs
>       `(("dialog" ,dialog)))
> @@ -6689,6 +6688,18 @@ provide an easy to use, pythonic and comprehensive Python interface to dialog.
>  This allows one to make simple text-mode user interfaces on Unix-like systems")
>      (license lgpl2.1)))
>  
> +(define-public python2-pythondialog
> +  (package-with-python2
> +    (package (inherit python-pythondialog)
> +      (name "python2-pythondialog")
> +      (source
> +       (origin
> +         (method url-fetch)
> +         (uri (pypi-uri "python2-pythondialog" version))
> +         (sha256
> +          (base32
> +           "0d8k7lxk50imdyx85lv8j98i4c93a71iwpapnl1506rpkbm9qvd9"))))))
> +
>  (define-public python-pyrfc3339
>    (package
>      (name "python-pyrfc3339")
> -- 
> 1.9.1
>
  
Vincent Legoll July 28, 2016, 10:52 a.m. UTC | #2
>> Is that what you want ?
>> This is still untested though, but I'll try the 2 packages
>
> I don't understand. Is this completely untested or have you tested this
> before sending the patch?

This patch is untested. I didn't manage to test it (see the other thread:
"guix package modif testing").
  
Vincent Legoll July 28, 2016, 10:53 a.m. UTC | #3
And actually the patch is wrong, I think it's missing a closing paren
for python2-pythondialog...
  

Patch

From 8b6becfd95235e1559cdb4a3760c5928d707e6cf Mon Sep 17 00:00:00 2001
From: Vincent Legoll <vincent.legoll@idgrilles.fr>
Date: Wed, 27 Jul 2016 14:28:06 +0200
Subject: [PATCH] Add python-pythondialog

Signed-off-by: Vincent Legoll <vincent.legoll@idgrilles.fr>
---
 gnu/packages/python.scm | 21 ++++++++++++++++-----
 1 file changed, 16 insertions(+), 5 deletions(-)

diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 80ff81f..533d731 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -6654,17 +6654,17 @@  facilities for defining, registering and looking up components.")
 (define-public python2-zope-component
   (package-with-python2 python-zope-component))
 
-(define-public python2-pythondialog
+(define-public python-pythondialog
   (package
-    (name "python2-pythondialog")
+    (name "python-pythondialog")
     (version "3.4.0")
     (source
      (origin
        (method url-fetch)
-       (uri (pypi-uri "python2-pythondialog" version))
+       (uri (pypi-uri "pythondialog" version))
        (sha256
         (base32
-         "0d8k7lxk50imdyx85lv8j98i4c93a71iwpapnl1506rpkbm9qvd9"))))
+         "1728ghsran47jczn9bhlnkvk5bvqmmbihabgif5h705b84r1272c"))))
     (build-system python-build-system)
     (arguments
      `(#:phases
@@ -6678,7 +6678,6 @@  facilities for defining, registering and looking up components.")
                  (("os.getenv\\(\"PATH\", \":/bin:/usr/bin\"\\)")
                   (string-append "os.getenv(\"PATH\")  + \":" dialog "/bin\"")))
                #t))))
-       #:python ,python-2
        #:tests? #f)) ; no test suite
     (propagated-inputs
      `(("dialog" ,dialog)))
@@ -6689,6 +6688,18 @@  provide an easy to use, pythonic and comprehensive Python interface to dialog.
 This allows one to make simple text-mode user interfaces on Unix-like systems")
     (license lgpl2.1)))
 
+(define-public python2-pythondialog
+  (package-with-python2
+    (package (inherit python-pythondialog)
+      (name "python2-pythondialog")
+      (source
+       (origin
+         (method url-fetch)
+         (uri (pypi-uri "python2-pythondialog" version))
+         (sha256
+          (base32
+           "0d8k7lxk50imdyx85lv8j98i4c93a71iwpapnl1506rpkbm9qvd9"))))))
+
 (define-public python-pyrfc3339
   (package
     (name "python-pyrfc3339")
-- 
1.9.1