Add trio (dependency of ghostscript)
Commit Message
Hi Guix,
I noticed that GNU Ghostscript (and the unpackaged AGPL Ghostscript)
bundles a few dependencies. One of them is trio.
Here’s a working build of this library that has been sitting in my “wip”
branch for more than a year.
~~ Ricardo
Comments
On Sat, Jul 23, 2016 at 01:36:41AM +0200, Ricardo Wurmus wrote:
> * gnu/packages/code.scm (trio): New variable.
LGTM
Leo Famulari <leo@famulari.name> writes:
> On Sat, Jul 23, 2016 at 01:36:41AM +0200, Ricardo Wurmus wrote:
>> * gnu/packages/code.scm (trio): New variable.
>
> LGTM
Thanks. Pushed as a4e6356e110bb2cd3ad90d8943fd6a700de97ca8.
~~ Ricardo
From 15ee46e1db30696c0f1dade014d619a8383dfa96 Mon Sep 17 00:00:00 2001
From: Ricardo Wurmus <rekado@elephly.net>
Date: Thu, 3 Sep 2015 13:28:25 +0200
Subject: [PATCH] gnu: Add trio.
* gnu/packages/code.scm (trio): New variable.
---
gnu/packages/code.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)
@@ -229,6 +229,29 @@ files, but compared to grep is much faster and respects files like .gitignore,
.hgignore, etc.")
(license license:asl2.0)))
+(define-public trio
+ (package
+ (name "trio")
+ (version "1.16")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/ctrio/trio/trio-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "02pwd5m5vq7hbrffgm2na1dfc249z50yyr5jv73vdw15bd7ygl44"))))
+ (build-system gnu-build-system)
+ (home-page "http://daniel.haxx.se/projects/trio/")
+ (synopsis "Portable and extendable printf and string functions")
+ (description
+ "Trio is a set of @code{printf} and string functions designed be used by
+applications with a focus on portability or with the need for additional
+features that are not supported by the standard @code{stdio} implementation.")
+ ;; This license is very similar to the ISC license, but the wording is
+ ;; slightly different.
+ (license (license:non-copyleft
+ "http://sourceforge.net/p/ctrio/git/ci/master/tree/README"))))
+
(define-public withershins
(package
(name "withershins")
--
2.8.4