gnu: Add texmaker.

Message ID 87y46z6yif.fsf@gnu.org
State New
Headers

Commit Message

Roel Janssen May 24, 2016, 7:34 p.m. UTC
  Ludovic Courtès writes:

> Roel Janssen <roel@gnu.org> skribis:
>
>> From fc657a31b4a52628c09a0b634c49b71cce2230bc Mon Sep 17 00:00:00 2001
>> From: Roel Janssen <roel@gnu.org>
>> Date: Tue, 24 May 2016 00:14:59 +0200
>> Subject: [PATCH 1/2] gnu: Rename texlive to tex.
>>
>> * gnu/local.mk (GNU_SYSTEM_MODULES): Rename texlive.scm to tex.scm.
>> * gnu/packages/texlive.scm: Rename file to tex.scm.
>> * gnu/packages/tex.scm: Renamed from texlive.scm.
>> * gnu/packages/algebra.scm: Rename texlive to tex.
>
> Here I’d just put “Adjust accordingly.”
>
>> * gnu/packages/docbook.scm: Rename texlive to tex.
>> * gnu/packages/engineering.scm: Rename texlive to tex.
>
> … and here “Likewise.” is enough.
>
> Apart from that LGTM!

I've changed the commit message.  Hopefully it's how you envisioned it
should be.  I modified the first line to be more clear about what is to
be renamed (the module, not the package).

This version of the patch also renames Efraim Flashner's recent addition
of texlive in photo.scm.

>> From f54915ab4ab70133adced8fd71649918e38ba659 Mon Sep 17 00:00:00 2001
>> From: Roel Janssen <roel@gnu.org>
>> Date: Tue, 24 May 2016 00:16:05 +0200
>> Subject: [PATCH 2/2] gnu: Add texmaker.
>>
>> * gnu/packages/tex.scm (texmaker): New variable.
>
> OK.
>
> I think it would help now if you could access the repo directly.  :-)
>
> What’s your Savannah account?  Please make sure to upload your current
> OpenPGP public key there.

Thanks!  My Savannah username is roelj.  I've created a new PGP key and
updated my account's public key accordingly.

May I sign and push these patches?

Kind regards,
Roel Janssen
  

Comments

Ludovic Courtès May 26, 2016, 7:56 a.m. UTC | #1
Hello!

Roel Janssen <roel@gnu.org> skribis:

> Ludovic Courtès writes:

[...]

>> I think it would help now if you could access the repo directly.  :-)
>>
>> What’s your Savannah account?  Please make sure to upload your current
>> OpenPGP public key there.
>
> Thanks!  My Savannah username is roelj.  I've created a new PGP key and
> updated my account's public key accordingly.

Awesome, welcome!  :-)

Please see ‘HACKING’.  If in doubt with Git or anything, don’t hesitate
to ask.  Also, make sure to sign commits that you push.

> May I sign and push these patches?

Yes, please!

Cheers,
Ludo’.
  
Roel Janssen May 26, 2016, 8:47 a.m. UTC | #2
Ludovic Courtès writes:

> Hello!
>
> Roel Janssen <roel@gnu.org> skribis:
>
>> Ludovic Courtès writes:
>
> [...]
>
>>> I think it would help now if you could access the repo directly.  :-)
>>>
>>> What’s your Savannah account?  Please make sure to upload your current
>>> OpenPGP public key there.
>>
>> Thanks!  My Savannah username is roelj.  I've created a new PGP key and
>> updated my account's public key accordingly.
>
> Awesome, welcome!  :-)
>
> Please see ‘HACKING’.  If in doubt with Git or anything, don’t hesitate
> to ask.  Also, make sure to sign commits that you push.
>
>> May I sign and push these patches?
>
> Yes, please!

Pushed.  Is there an interface other than the following command to
verify the commits are signed?:

  git --no-pager log --show-signature -1

Thanks!

Kind regards,
Roel Janssen
  
Leo Famulari May 26, 2016, 4:15 p.m. UTC | #3
On Thu, May 26, 2016 at 10:47:46AM +0200, Roel Janssen wrote:
> Pushed.  Is there an interface other than the following command to
> verify the commits are signed?:
> 
>   git --no-pager log --show-signature -1

`git verify-commit` can be used to programmatically verify the
signatures of commits. I sent an example of how to use it in the
'pre-push' hook attached to this message:

http://lists.gnu.org/archive/html/guix-devel/2016-05/msg00661.html
  

Patch

From 1a7e23191fe4371f6d65b04b839f5fbb464e054a Mon Sep 17 00:00:00 2001
From: Roel Janssen <roel@gnu.org>
Date: Tue, 24 May 2016 21:23:31 +0200
Subject: [PATCH 2/2] gnu: Add texmaker.

* gnu/packages/tex.scm (texmaker): New variable.
---
 gnu/packages/tex.scm | 39 +++++++++++++++++++++++++++++++++++++++
 1 file changed, 39 insertions(+)

diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index eab85f1..c1ab8b3 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -2,6 +2,7 @@ 
 ;;; Copyright © 2013, 2014, 2015, 2016 Andreas Enge <andreas@enge.fr>
 ;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
 ;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
+;;; Copyright © 2016 Roel Janssen <roel@gnu.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -40,6 +41,7 @@ 
   #:use-module (gnu packages perl)
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages python)
+  #:use-module (gnu packages qt)
   #:use-module (gnu packages ruby)
   #:use-module (gnu packages tcsh)
   #:use-module (gnu packages base)
@@ -387,3 +389,40 @@  to manage bibliographic references.  Automatic execution of dvips to produce
 PostScript documents is also included, as well as usage of pdfLaTeX to produce
 PDF documents.")
     (license license:gpl2+)))
+
+(define-public texmaker
+  (package
+    (name "texmaker")
+    (version "4.5")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "http://www.xm1math.net/texmaker/texmaker-"
+                                  version ".tar.bz2"))
+              (sha256
+               (base32
+                "056njk6j8wma23mlp7xa3rgfaxx0q8ynwx8wkmj7iy0b85p9ds9c"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         ;; Qt has its own configuration utility.
+         (replace 'configure
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let ((out (assoc-ref outputs "out")))
+               (zero? (system* "qmake"
+                               (string-append "PREFIX=" out)
+                               (string-append "DESKTOPDIR=" out
+                                              "/share/applications")
+                               (string-append "ICONDIR=" out "/share/pixmaps")
+                               "texmaker.pro"))))))))
+    (inputs
+     `(("poppler-qt5" ,poppler-qt5)
+       ("qt" ,qt)
+       ("zlib" ,zlib)))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
+    (home-page "http://www.xm1math.net/texmaker/")
+    (synopsis "LaTeX editor")
+    (description "Texmaker is a program that integrates many tools needed to
+develop documents with LaTeX, in a single application.")
+    (license license:gpl2+)))
-- 
2.8.3