Commit Message
Good Day,
This patch is part of a series of patches related to rails@4.2.6. I'll
send a couple at time once the previous ones have been accepted.
Respectuflly,
Comments
On Tue, May 31, 2016 at 11:32:45AM -0400, Matthew Jordan wrote:
>
> Good Day,
>
> This patch is part of a series of patches related to rails@4.2.6. I'll
> send a couple at time once the previous ones have been accepted.
>
> From ee75250f7328aae1bf1886c730d2cbe4b30ea91a Mon Sep 17 00:00:00 2001
> From: Matthew Jordan <matthewjordandevops@yandex.com>
> Date: Tue, 31 May 2016 07:26:24 -0400
> Subject: [PATCH 1/4] gnu: Add ruby-debug-inspector.
>
> * gnu/local.mk: Modfied file.
> * gnu/packages/rails.scm: New file.
> ---
> gnu/local.mk | 1 +
> gnu/packages/rails.scm | 53 ++++++++++++++++++++++++++++++++++++++++++++++++++
> 2 files changed, 54 insertions(+)
> create mode 100644 gnu/packages/rails.scm
>
> diff --git a/gnu/local.mk b/gnu/local.mk
> index 86b56d4..4c21827 100644
> --- a/gnu/local.mk
> +++ b/gnu/local.mk
> @@ -285,6 +285,7 @@ GNU_SYSTEM_MODULES = \
> %D%/packages/qemu.scm \
> %D%/packages/qt.scm \
> %D%/packages/ragel.scm \
> + %D%/packages/rails.scm \
> %D%/packages/ratpoison.scm \
> %D%/packages/rc.scm \
> %D%/packages/rdesktop.scm \
> diff --git a/gnu/packages/rails.scm b/gnu/packages/rails.scm
> new file mode 100644
> index 0000000..8241c18
> --- /dev/null
> +++ b/gnu/packages/rails.scm
> @@ -0,0 +1,53 @@
> +;;; GNU Guix --- Functional package management for GNU
> +;;; Copyright © 2016 Matthew Jordan <matthewjordandevops@yandex.com>
> +;;;
> +;;; This file is part of GNU Guix.
> +;;;
> +;;; GNU Guix is free software; you can redistribute it and/or modify it
> +;;; under the terms of the GNU General Public License as published by
> +;;; the Free Software Foundation; either version 3 of the License, or (at
> +;;; your option) any later version.
> +;;;
> +;;; GNU Guix is distributed in the hope that it will be useful, but
> +;;; WITHOUT ANY WARRANTY; without even the implied warranty of
> +;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
> +;;; GNU General Public License for more details.
> +;;;
> +;;; You should have received a copy of the GNU General Public License
> +;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
> +
> +(define-module (gnu packages rails)
> + #:use-module (guix licenses)
> + #:use-module (gnu packages)
> + #:use-module (guix download)
> + #:use-module (guix packages)
> + #:use-module (gnu packages base)
> + #:use-module (gnu packages python)
> + #:use-module (gnu packages node)
> + #:use-module (gnu packages ruby)
> + #:use-module (gnu packages gcc)
> + #:use-module (guix build-system ruby))
> +
> +(define-public ruby-debug-inspector
> + (package
> + (name "ruby-debug-inspector")
> + (version "0.0.2")
> + (source
> + (origin
> + (method url-fetch)
> + (uri (rubygems-uri "debug_inspector" version))
> + (sha256
> + (base32
> + "109761g00dbrw5q0dfnbqg8blfm699z4jj70l4zrgf9mzn7ii50m"))))
> + (build-system ruby-build-system)
> + (arguments
> + `(#:tests? #f))
Why are the tests not run? Please include a comment explaining.
> + (inputs
> + `(("ruby-bacon" ,ruby-bacon)))
> + (synopsis
> + "A Ruby wrapper for the MRI 2.0 debug_inspector API")
> + (description
> + "This package provides a Ruby wrapper for the MRI 2.0 debug_inspector API")
^^^
needs a period at the end
> + (home-page
> + "https://github.com/banister/debug_inspector")
> + (license #f)))
^^^
oops ;)
> --
> 2.8.3
>
>
> Respectuflly,
>
> --
> Matthew Jordan
> Sent with my mu4e
From ee75250f7328aae1bf1886c730d2cbe4b30ea91a Mon Sep 17 00:00:00 2001
From: Matthew Jordan <matthewjordandevops@yandex.com>
Date: Tue, 31 May 2016 07:26:24 -0400
Subject: [PATCH 1/4] gnu: Add ruby-debug-inspector.
* gnu/local.mk: Modfied file.
* gnu/packages/rails.scm: New file.
---
gnu/local.mk | 1 +
gnu/packages/rails.scm | 53 ++++++++++++++++++++++++++++++++++++++++++++++++++
2 files changed, 54 insertions(+)
create mode 100644 gnu/packages/rails.scm
@@ -285,6 +285,7 @@ GNU_SYSTEM_MODULES = \
%D%/packages/qemu.scm \
%D%/packages/qt.scm \
%D%/packages/ragel.scm \
+ %D%/packages/rails.scm \
%D%/packages/ratpoison.scm \
%D%/packages/rc.scm \
%D%/packages/rdesktop.scm \
new file mode 100644
@@ -0,0 +1,53 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2016 Matthew Jordan <matthewjordandevops@yandex.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages rails)
+ #:use-module (guix licenses)
+ #:use-module (gnu packages)
+ #:use-module (guix download)
+ #:use-module (guix packages)
+ #:use-module (gnu packages base)
+ #:use-module (gnu packages python)
+ #:use-module (gnu packages node)
+ #:use-module (gnu packages ruby)
+ #:use-module (gnu packages gcc)
+ #:use-module (guix build-system ruby))
+
+(define-public ruby-debug-inspector
+ (package
+ (name "ruby-debug-inspector")
+ (version "0.0.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "debug_inspector" version))
+ (sha256
+ (base32
+ "109761g00dbrw5q0dfnbqg8blfm699z4jj70l4zrgf9mzn7ii50m"))))
+ (build-system ruby-build-system)
+ (arguments
+ `(#:tests? #f))
+ (inputs
+ `(("ruby-bacon" ,ruby-bacon)))
+ (synopsis
+ "A Ruby wrapper for the MRI 2.0 debug_inspector API")
+ (description
+ "This package provides a Ruby wrapper for the MRI 2.0 debug_inspector API")
+ (home-page
+ "https://github.com/banister/debug_inspector")
+ (license #f)))
--
2.8.3