Commit Message
This is dependent on ruby-debug-inspector patch.
--
Matthew Jordan
Sent with my mu4e
Comments
On 01/06/16 01:36, Matthew Jordan wrote:
> This is dependent on ruby-debug-inspector patch.
I'm more supportive of this being in a new rails.scm file than
ruby-debug-inspector. I made some changes to your patch. Here's the
diff, WDYT?
I think it could still do with an improved synopsis and description at
least. Would you like to do this and submit a properly formatted patch
please?
Thanks.
+
+(define-public ruby-spring
+ (package
+ (name "ruby-spring")
+ (version "1.7.1")
+ (source
+ (origin
+ (method url-fetch)
+ ;; Fetch from github as the gem does not contain testing code.
+ (uri (string-append
+ "https://github.com/rails/spring/archive/v"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0czc4mkwfngcqmna49a0l98f6wlhdq2i8gwr63lrmk90d9k25x1n"))))
+ (build-system ruby-build-system)
+ (arguments
+ `(#:test-target "test:unit"
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'remove-bump
+ (lambda _
+ (substitute* "spring.gemspec"
+ (("gem.add_development_dependency 'bump'") ""))
+ (substitute* "Rakefile"
+ (("require \\\"bump/tasks\\\"") ""))
+ #t)))))
+ (native-inputs
+ `(("bundler" ,bundler)
+ ("ruby-activesupport" ,ruby-activesupport)))
+ (synopsis
+ "Preloads your application so things like console, rake and tests
run faster")
+ (description
+ "Preloads your application so things like console, rake and tests
run faster")
+ (home-page "https://github.com/rails/spring")
+ (license license:expat)))
From a7cf3f9f00e29af7a07fead35689da9f47dd98cb Mon Sep 17 00:00:00 2001
From: Matthew Jordan <matthewjordandevops@yandex.com>
Date: Tue, 31 May 2016 07:29:24 -0400
Subject: [PATCH 2/4] gnu: Add ruby-spring.
* gnu/packages/rails.scm: Modified file.
---
gnu/packages/rails.scm | 21 +++++++++++++++++++++
1 file changed, 21 insertions(+)
@@ -28,6 +28,27 @@
#:use-module (gnu packages gcc)
#:use-module (guix build-system ruby))
+(define-public ruby-spring
+ (package
+ (name "ruby-spring")
+ (version "1.7.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "spring" version))
+ (sha256
+ (base32
+ "165f6n6am36md1lzaivcg9bx09f7iph4vab0f8av2rlza4yi791p"))))
+ (build-system ruby-build-system)
+ (arguments
+ `(#:tests? #f))
+ (synopsis
+ "Preloads your application so things like console, rake and tests run faster")
+ (description
+ "Preloads your application so things like console, rake and tests run faster")
+ (home-page "https://github.com/rails/spring")
+ (license expat)))
+
(define-public ruby-debug-inspector
(package
(name "ruby-debug-inspector")
--
2.8.3