ruby-byebug@9.0.5

Message ID 87shwyxmnv.fsf@mailerver.i-did-not-set--mail-host-address--so-tickle-me
State New
Headers

Commit Message

Matthew Jordan May 31, 2016, 3:38 p.m. UTC
  
  

Comments

Ben Woodcroft June 2, 2016, 10:19 a.m. UTC | #1
Hi Matthew.

Thank you for the patch.

On 06/01/2016 01:38 AM, Matthew Jordan wrote:
> +(define-public ruby-byebug-9

Is there a reason this variable includes "-9"? Since 9.0.5 is the newest 
version, I don't think it is necessary.

> +  (package
> +    (name "ruby-byebug")
> +    (version "9.0.5")
> +    (source
> +     (origin
> +       (method url-fetch)
> +       (uri (rubygems-uri "byebug" version))
> +       (sha256
> +        (base32
> +         "18sdnscwwm76i2kbcib2ckwfwpq8b1dbfr97gdcx3j1x547yqv9x"))))
> +    (build-system ruby-build-system)
> +    (arguments
> +     `(#:tests? #f))

I imagine you disabled tests because there was no Rakefile in the gem. 
In that case, we should source byebug from a release on GitHub, so that 
we can run the tests. I hope there are not too many dependent packages.

> +    (synopsis "Byebug is a Ruby 2 debugger.")

Perhaps simply "A Ruby 2 debugger" omitting the full stop at the end as 
per 'guix lint'?

> +    (description
> +     "Byebug is a Ruby 2 debugger.  It's implemented using the Ruby 2
> +TracePoint C API for execution control and the Debug Inspector C API for call
> +stack navigation.  The core component provides support that front-ends can
> +build on.  It provides breakpoint handling and bindings for stack frames among
> +other things and it comes with an easy to use command line interface.")

Other than s/It's/It is/ I think. I'm not sure of the policy on 
abbreviations, but that feels right to me.

> +    (home-page
> +"http://github.com/deivid-rodriguez/byebug")
> +    (license license:bsd-3)))

Thanks,
ben
  

Patch

From db2eb23978143363861b780fa43e28301b70f464 Mon Sep 17 00:00:00 2001
From: Matthew Jordan <matthewjordandevops@yandex.com>
Date: Tue, 31 May 2016 07:31:37 -0400
Subject: [PATCH 3/4] gnu: Add ruby-byebug@9.0.5

* gnu/packages/rails.scm: Modified file.
---
 gnu/packages/ruby.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)

diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 6eebd9a..595abeb 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -2721,6 +2721,31 @@  with PostgreSQL 8.4 and later.")
     (home-page "https://bitbucket.org/ged/ruby-pg")
     (license license:ruby)))
 
+(define-public ruby-byebug-9
+  (package
+    (name "ruby-byebug")
+    (version "9.0.5")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (rubygems-uri "byebug" version))
+       (sha256
+        (base32
+         "18sdnscwwm76i2kbcib2ckwfwpq8b1dbfr97gdcx3j1x547yqv9x"))))
+    (build-system ruby-build-system)
+    (arguments
+     `(#:tests? #f))
+    (synopsis "Byebug is a Ruby 2 debugger.")
+    (description
+     "Byebug is a Ruby 2 debugger.  It's implemented using the Ruby 2
+TracePoint C API for execution control and the Debug Inspector C API for call
+stack navigation.  The core component provides support that front-ends can
+build on.  It provides breakpoint handling and bindings for stack frames among
+other things and it comes with an easy to use command line interface.")
+    (home-page
+     "http://github.com/deivid-rodriguez/byebug")
+    (license license:bsd-3)))
+
 (define-public ruby-byebug
   (package
     (name "ruby-byebug")
-- 
2.8.3