gnu: Add emacs-company.

Message ID 87shwcwa63.fsf@elephly.net
State New
Headers

Commit Message

Ricardo Wurmus June 17, 2016, 7:23 a.m. UTC
  Ben Woodcroft <b.woodcroft@uq.edu.au> writes:

> On 17/06/16 16:12, Ricardo Wurmus wrote:
[...]
>> +    ;; The tests cannot be built because the file "company-tests" is not part
>> +    ;; of the tarball.
>
> It is part of the GitHub releases though e.g. at
> https://github.com/company-mode/company-mode/tree/e085a333867959a1b36015a3ad8e12e5bd6550d9
>
> Would it make sense to source from GitHub instead?

Yes, thanks for the pointer.  Here’s a new patch.

~~ Ricardo
  

Comments

Ludovic Courtès June 17, 2016, 3:10 p.m. UTC | #1
Ricardo Wurmus <rekado@elephly.net> skribis:

> From a4e0f28d8d77002d9f4907418190531b508ebca6 Mon Sep 17 00:00:00 2001
> From: Ricardo Wurmus <rekado@elephly.net>
> Date: Fri, 17 Jun 2016 08:11:49 +0200
> Subject: [PATCH] gnu: Add emacs-company.
>
> * gnu/packages/emacs.scm (emacs-company): New variable.

[...]

> +     "Company is a modular completion mechanism.  Modules for retrieving
> +completion candidates are called back-ends, modules for displaying them are
> +front-ends.  Company comes with many back-ends, e.g. `company-elisp'.  These

@code{company-elisp}

Otherwise LGTM, thanks!

Ludo’.
  
Ricardo Wurmus June 17, 2016, 7:19 p.m. UTC | #2
Ludovic Courtès <ludo@gnu.org> writes:

> Ricardo Wurmus <rekado@elephly.net> skribis:
>
>> From a4e0f28d8d77002d9f4907418190531b508ebca6 Mon Sep 17 00:00:00 2001
>> From: Ricardo Wurmus <rekado@elephly.net>
>> Date: Fri, 17 Jun 2016 08:11:49 +0200
>> Subject: [PATCH] gnu: Add emacs-company.
>>
>> * gnu/packages/emacs.scm (emacs-company): New variable.
>
> [...]
>
>> +     "Company is a modular completion mechanism.  Modules for retrieving
>> +completion candidates are called back-ends, modules for displaying them are
>> +front-ends.  Company comes with many back-ends, e.g. `company-elisp'.  These
>
> @code{company-elisp}

Right.  Fixed it and pushed to master.

Thanks!

~~ Ricardo
  

Patch

From a4e0f28d8d77002d9f4907418190531b508ebca6 Mon Sep 17 00:00:00 2001
From: Ricardo Wurmus <rekado@elephly.net>
Date: Fri, 17 Jun 2016 08:11:49 +0200
Subject: [PATCH] gnu: Add emacs-company.

* gnu/packages/emacs.scm (emacs-company): New variable.
---
 gnu/packages/emacs.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)

diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index cb6464d..a80d9ce 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -1333,6 +1333,29 @@  view the build status of those servers' build jobs, and possibly to trigger
 build jobs.")
     (license license:gpl3+)))
 
+(define-public emacs-company
+  (package
+    (name "emacs-company")
+    (version "0.8.12")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://github.com/company-mode/company-mode/archive/"
+                           version ".tar.gz"))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "1vwmbqm7h4lrszv2qxy6fqzznm9raigi84cadx982c9m7shp0zzz"))))
+    (build-system emacs-build-system)
+    (home-page "http://company-mode.github.io/")
+    (synopsis "Modular text completion framework")
+    (description
+     "Company is a modular completion mechanism.  Modules for retrieving
+completion candidates are called back-ends, modules for displaying them are
+front-ends.  Company comes with many back-ends, e.g. `company-elisp'.  These
+are distributed in separate files and can be used individually.")
+    (license license:gpl3+)))
+
 (define-public typo
   (package
     (name "emacs-typo")
-- 
2.8.3