gnu: Add poppler-qt5.

Message ID 87r3ctzly6.fsf@gnu.org
State Committed
Headers

Commit Message

Roel Janssen May 22, 2016, 11:56 p.m. UTC
  Dear Guix,

I need poppler-qt5 for Texmaker (see other patch), so here is a patch:

>From ef330ec9125246f81094ac36c2f564f3f3fca029 Mon Sep 17 00:00:00 2001
From: Roel Janssen <roel@gnu.org>
Date: Mon, 23 May 2016 01:47:11 +0200
Subject: [PATCH] gnu: Add poppler-qt5.

* gnu/packages/pdf.scm (poppler-qt5): New variable.
---
 gnu/packages/pdf.scm | 7 +++++++
 1 file changed, 7 insertions(+)
  

Comments

Efraim Flashner May 23, 2016, 11:40 a.m. UTC | #1
On Mon, May 23, 2016 at 01:56:17AM +0200, Roel Janssen wrote:
> Dear Guix,
> 
> I need poppler-qt5 for Texmaker (see other patch), so here is a patch:
> 
> >From ef330ec9125246f81094ac36c2f564f3f3fca029 Mon Sep 17 00:00:00 2001
> From: Roel Janssen <roel@gnu.org>
> Date: Mon, 23 May 2016 01:47:11 +0200
> Subject: [PATCH] gnu: Add poppler-qt5.
> 
> * gnu/packages/pdf.scm (poppler-qt5): New variable.
> ---
>  gnu/packages/pdf.scm | 7 +++++++
>  1 file changed, 7 insertions(+)
> 
> diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
> index ef05def..d577afd 100644
> --- a/gnu/packages/pdf.scm
> +++ b/gnu/packages/pdf.scm
> @@ -109,6 +109,13 @@
>               ,@(package-inputs poppler)))
>     (synopsis "Qt4 frontend for the Poppler PDF rendering library")))
>  
> +(define-public poppler-qt5
> +  (package (inherit poppler)
> +   (name "poppler-qt5")
> +   (inputs `(("qt" ,qt)
> +             ,@(package-inputs poppler)))
> +   (synopsis "Qt5 frontend for the Poppler PDF rendering library")))
> +
>  (define-public python-poppler-qt4
>    (package
>      (name "python-poppler-qt4")
> -- 
> 2.7.4
> 

This looks good and built fine.
I added a copyright line for you at the top and pushed it.
  
Roel Janssen May 23, 2016, 11:46 a.m. UTC | #2
Efraim Flashner writes:

> On Mon, May 23, 2016 at 01:56:17AM +0200, Roel Janssen wrote:
>> Dear Guix,
>> 
>> I need poppler-qt5 for Texmaker (see other patch), so here is a patch:
>> 
>> >From ef330ec9125246f81094ac36c2f564f3f3fca029 Mon Sep 17 00:00:00 2001
>> From: Roel Janssen <roel@gnu.org>
>> Date: Mon, 23 May 2016 01:47:11 +0200
>> Subject: [PATCH] gnu: Add poppler-qt5.
>> 
>> * gnu/packages/pdf.scm (poppler-qt5): New variable.
>> ---
>>  gnu/packages/pdf.scm | 7 +++++++
>>  1 file changed, 7 insertions(+)
>> 
>> diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
>> index ef05def..d577afd 100644
>> --- a/gnu/packages/pdf.scm
>> +++ b/gnu/packages/pdf.scm
>> @@ -109,6 +109,13 @@
>>               ,@(package-inputs poppler)))
>>     (synopsis "Qt4 frontend for the Poppler PDF rendering library")))
>>  
>> +(define-public poppler-qt5
>> +  (package (inherit poppler)
>> +   (name "poppler-qt5")
>> +   (inputs `(("qt" ,qt)
>> +             ,@(package-inputs poppler)))
>> +   (synopsis "Qt5 frontend for the Poppler PDF rendering library")))
>> +
>>  (define-public python-poppler-qt4
>>    (package
>>      (name "python-poppler-qt4")
>> -- 
>> 2.7.4
>> 
>
> This looks good and built fine.
> I added a copyright line for you at the top and pushed it.

Thanks for your time and effort!

Kind regards,
Roel Janssen
  

Patch

diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index ef05def..d577afd 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -109,6 +109,13 @@ 
              ,@(package-inputs poppler)))
    (synopsis "Qt4 frontend for the Poppler PDF rendering library")))
 
+(define-public poppler-qt5
+  (package (inherit poppler)
+   (name "poppler-qt5")
+   (inputs `(("qt" ,qt)
+             ,@(package-inputs poppler)))
+   (synopsis "Qt5 frontend for the Poppler PDF rendering library")))
+
 (define-public python-poppler-qt4
   (package
     (name "python-poppler-qt4")