Commit Message
Hello all!
Here's a patch to update Python to the latest version. I can confirm
that it builds fine. I'm guessing it needs to go into core-updates
though because this probably affects a lot of things?
I also intend to look at Diane's work on Python 3.5 to see if I can help
move that along.
- Chris
Comments
On Mon, Jun 20, 2016 at 02:18:49PM -0500, Christopher Allan Webber wrote:
> Hello all!
>
> Here's a patch to update Python to the latest version. I can confirm
> that it builds fine. I'm guessing it needs to go into core-updates
> though because this probably affects a lot of things?
We received a patch for this a little while ago, and I think we wanted
to work on 3.5 instead, since either 3.4.4 or 3.5 will require a lot of
rebuilding. Maybe we should have a python-updates branch?
Leo Famulari writes:
> On Mon, Jun 20, 2016 at 02:18:49PM -0500, Christopher Allan Webber wrote:
>> Hello all!
>>
>> Here's a patch to update Python to the latest version. I can confirm
>> that it builds fine. I'm guessing it needs to go into core-updates
>> though because this probably affects a lot of things?
>
> We received a patch for this a little while ago, and I think we wanted
> to work on 3.5 instead, since either 3.4.4 or 3.5 will require a lot of
> rebuilding. Maybe we should have a python-updates branch?
I have python-3.5 building here. I'm working so that a python-3.4
package can still be kept around alongside that... verifying that it
builds successfully, then I'll submit a patch for Python 3.5 which
builds on this patch, so we can both update python3.4 to 3.4.4 and also
switch over most libraries programs to using python3.5 at the same time.
How does that sound?
- Chris
On Tue, Jun 21, 2016 at 09:44:25AM -0500, Christopher Allan Webber wrote:
> Leo Famulari writes:
>
> > On Mon, Jun 20, 2016 at 02:18:49PM -0500, Christopher Allan Webber wrote:
> >> Hello all!
> >>
> >> Here's a patch to update Python to the latest version. I can confirm
> >> that it builds fine. I'm guessing it needs to go into core-updates
> >> though because this probably affects a lot of things?
> >
> > We received a patch for this a little while ago, and I think we wanted
> > to work on 3.5 instead, since either 3.4.4 or 3.5 will require a lot of
> > rebuilding. Maybe we should have a python-updates branch?
>
> I have python-3.5 building here. I'm working so that a python-3.4
> package can still be kept around alongside that... verifying that it
> builds successfully, then I'll submit a patch for Python 3.5 which
> builds on this patch, so we can both update python3.4 to 3.4.4 and also
> switch over most libraries programs to using python3.5 at the same time.
>
> How does that sound?
Sounds good :)
From b41ddd042730895a1ce257943018099c98053eac Mon Sep 17 00:00:00 2001
From: Christopher Allan Webber <cwebber@dustycloud.org>
Date: Mon, 20 Jun 2016 14:05:20 -0500
Subject: [PATCH] gnu: python-3.4: Update to 3.4.4.
* gnu/packages/python.scm (python-3.4): Update to 3.4.4.
---
gnu/packages/python.scm | 6 ++----
1 file changed, 2 insertions(+), 4 deletions(-)
@@ -271,21 +271,19 @@ data types.")
(define-public python-3.4
(package (inherit python-2)
- (version "3.4.3")
+ (version "3.4.4")
(source (origin
(method url-fetch)
(uri (string-append "https://www.python.org/ftp/python/"
version "/Python-" version ".tar.xz"))
(patches (search-patches
"python-fix-tests.patch"
- ;; XXX Try removing this patch for python > 3.4.3
- "python-disable-ssl-test.patch"
"python-3-deterministic-build-info.patch"
"python-3-search-paths.patch"))
(patch-flags '("-p0"))
(sha256
(base32
- "1f4nm4z08sy0kqwisvv95l02crv6dyysdmx44p1mz3bn6csrdcxm"))))
+ "18kb5c29w04rj4gyz3jngm72sy8izfnbjlm6ajv6rv2m061d75x7"))))
(arguments (substitute-keyword-arguments (package-arguments python-2)
((#:tests? _) #t)))
(native-search-paths
--
2.8.4