Commit Message
Good Day,
> Thanks! Can you test the attached revision on your patch? Here are the
> changes:
Hi I tried applying to patch and git gave me an error asking if I hand
edited the patch file.
So I added the changes to the attached patch. Let me know if I covered everything.
---
Matthew Jordan
From f6d471c2292e6b0a70b84d46653fba15d0b823dc Mon Sep 17 00:00:00 2001
From: Matthew Jordan <matthewjordandevops@yandex.com>
Date: Wed, 18 May 2016 18:20:30 -0400
Subject: [PATCH] gnu: Add Tmux themepack
* gnu/packages/tmux.scm (tmux-themepack): New variable.
---
gnu/packages/tmux.scm | 42 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 42 insertions(+)
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Cyril Roelandt <tipecaml@gmail.com>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016 Matthew Jordan <matthewjordandevops@yandex.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -21,11 +22,16 @@
#:use-module (guix licenses)
#:use-module (guix packages)
#:use-module (guix download)
+ #:use-module (guix git-download)
+ #:use-module (guix utils)
+ #:use-module (guix build utils)
#:use-module (guix build-system gnu)
#:use-module (gnu packages)
+ #:use-module (gnu packages base)
#:use-module (gnu packages libevent)
#:use-module (gnu packages ncurses))
+
(define-public tmux
(package
(name "tmux")
@@ -50,3 +56,39 @@ windows), each running a separate program, to be created, accessed, and
controlled from a single screen. tmux may be detached from a screen and
continue running in the background, then later reattached.")
(license isc)))
+
+(define-public tmux-themepack
+ (let ((commit "03a372866f7677f7fe63bcee140b48b9fd372c48")
+ (revision "1"))
+ (package
+ (name "tmux-themepack")
+ (version
+ (string-append "0.0.0-" revision "." (string-take commit 7))) ;; No version tags
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url
+ (string-append "https://github.com/jimeh/" name ".git"))
+ (commit commit)))
+ (sha256
+ (base32
+ "1d3k87mq5lca042jbap5kxskjy3kg79wjhhpnm6jacbn3anc67zl"))
+ (file-name (string-append name "-" version "-checkout"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; Not tests
+ #:phases (modify-phases %standard-phases
+ (delete 'configure)
+ (delete 'build)
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (string-append
+ (assoc-ref outputs "out")
+ "/share/" ,name "-" ,version)))
+ (mkdir-p out)
+ (copy-recursively "." out)))))))
+ (home-page "https://github.com/jimeh/tmux-themepack")
+ (synopsis "Collection of themes for Tmux")
+ (description "A collection of various themes for Tmux.")
+ (license
+ (non-copyleft "http://www.wtfpl.net/txt/copying/")))))
--
2.9.0