Commit Message
Dear Guix,
Here is another R package.
Thank you for your time.
Kind regards,
Roel Janssen
>From 9afdfc2d9f8d2f0268878a9f16394c862f7dfb2b Mon Sep 17 00:00:00 2001
From: Roel Janssen <roel@gnu.org>
Date: Mon, 9 May 2016 13:42:31 +0200
Subject: [PATCH] gnu: Add r-mass.
* gnu/packages/statistics.scm (r-mass): New variable.
---
gnu/packages/statistics.scm | 20 ++++++++++++++++++++
1 file changed, 20 insertions(+)
Comments
Roel Janssen <roel@gnu.org> writes:
> Dear Guix,
>
> Here is another R package.
> Thank you for your time.
>
> Kind regards,
> Roel Janssen
>
>>From 9afdfc2d9f8d2f0268878a9f16394c862f7dfb2b Mon Sep 17 00:00:00 2001
> From: Roel Janssen <roel@gnu.org>
> Date: Mon, 9 May 2016 13:42:31 +0200
> Subject: [PATCH] gnu: Add r-mass.
>
> * gnu/packages/statistics.scm (r-mass): New variable.
Isn’t MASS one of the default packages that come with R? We’ve
previously added a package that is among the default packages, but I
don’t remember if that was a good decision.
Do you happen to know if this is considerably different from the
recommended and bundled package that comes with R?
> gnu/packages/statistics.scm | 20 ++++++++++++++++++++
> 1 file changed, 20 insertions(+)
>
> diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
> index 7b34832..10df5df 100644
> --- a/gnu/packages/statistics.scm
> +++ b/gnu/packages/statistics.scm
> @@ -333,6 +333,26 @@ support for the type of right-hand side expressions. For more information,
> see package vignette. To quote Rene Magritte, \"Ceci n'est pas un pipe.\"")
> (license license:expat)))
>
> +(define-public r-mass
> + (package
> + (name "r-mass")
> + (version "7.3-45")
> + (source (origin
> + (method url-fetch)
> + (uri (cran-uri "MASS" version))
> + (sha256
> + (base32
> + "13lp5919h2bnpmf8rbmkar8a41yx62fnx66pkvljvqf60wa29qsx"))))
> + (properties `((upstream-name . "MASS")))
> + (build-system r-build-system)
> + (home-page "http://www.stats.ox.ac.uk/pub/MASS4/")
> + (synopsis "This package contains functions and datasets for Venables and
> +Ripley's MASS")
This doesn’t need to be a full sentence. It would be sufficient to
start with “Functions and datasets...”.
> + (description "This package provides functions and datasets to support
> +the book by Venables and Ripley: Modern Applied Statistics with S (4th edition,
> +2002).")
What does “to support the book” mean? Could this be expressed more clearly?
Thanks!
~~ Ricardo
Ricardo Wurmus writes:
> Roel Janssen <roel@gnu.org> writes:
>
>> Dear Guix,
>>
>> Here is another R package.
>> Thank you for your time.
>>
>> Kind regards,
>> Roel Janssen
>>
>>>From 9afdfc2d9f8d2f0268878a9f16394c862f7dfb2b Mon Sep 17 00:00:00 2001
>> From: Roel Janssen <roel@gnu.org>
>> Date: Mon, 9 May 2016 13:42:31 +0200
>> Subject: [PATCH] gnu: Add r-mass.
>>
>> * gnu/packages/statistics.scm (r-mass): New variable.
>
> Isn’t MASS one of the default packages that come with R? We’ve
> previously added a package that is among the default packages, but I
> don’t remember if that was a good decision.
>
> Do you happen to know if this is considerably different from the
> recommended and bundled package that comes with R?
Nice! I didn't know it was indeed one of the default packages that come with R.
I tried to build packages depending on MASS and they seem to function.
So that means we don't need to look further at this patch.
>> gnu/packages/statistics.scm | 20 ++++++++++++++++++++
>> 1 file changed, 20 insertions(+)
>>
>> diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
>> index 7b34832..10df5df 100644
>> --- a/gnu/packages/statistics.scm
>> +++ b/gnu/packages/statistics.scm
>> @@ -333,6 +333,26 @@ support for the type of right-hand side expressions. For more information,
>> see package vignette. To quote Rene Magritte, \"Ceci n'est pas un pipe.\"")
>> (license license:expat)))
>>
>> +(define-public r-mass
>> + (package
>> + (name "r-mass")
>> + (version "7.3-45")
>> + (source (origin
>> + (method url-fetch)
>> + (uri (cran-uri "MASS" version))
>> + (sha256
>> + (base32
>> + "13lp5919h2bnpmf8rbmkar8a41yx62fnx66pkvljvqf60wa29qsx"))))
>> + (properties `((upstream-name . "MASS")))
>> + (build-system r-build-system)
>> + (home-page "http://www.stats.ox.ac.uk/pub/MASS4/")
>> + (synopsis "This package contains functions and datasets for Venables and
>> +Ripley's MASS")
>
> This doesn’t need to be a full sentence. It would be sufficient to
> start with “Functions and datasets...”.
>
>> + (description "This package provides functions and datasets to support
>> +the book by Venables and Ripley: Modern Applied Statistics with S (4th edition,
>> +2002).")
>
> What does “to support the book” mean? Could this be expressed more clearly?
>
> Thanks!
>
> ~~ Ricardo
Thanks for your time!
Kind regards,
Roel Janssen
@@ -333,6 +333,26 @@ support for the type of right-hand side expressions. For more information,
see package vignette. To quote Rene Magritte, \"Ceci n'est pas un pipe.\"")
(license license:expat)))
+(define-public r-mass
+ (package
+ (name "r-mass")
+ (version "7.3-45")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "MASS" version))
+ (sha256
+ (base32
+ "13lp5919h2bnpmf8rbmkar8a41yx62fnx66pkvljvqf60wa29qsx"))))
+ (properties `((upstream-name . "MASS")))
+ (build-system r-build-system)
+ (home-page "http://www.stats.ox.ac.uk/pub/MASS4/")
+ (synopsis "This package contains functions and datasets for Venables and
+Ripley's MASS")
+ (description "This package provides functions and datasets to support
+the book by Venables and Ripley: Modern Applied Statistics with S (4th edition,
+2002).")
+ (license license:gpl2+)))
+
(define-public r-munsell
(package
(name "r-munsell")