Commit Message
Leo Famulari writes:
> On Fri, Mar 18, 2016 at 07:53:39PM +0100, Andreas Enge wrote:
>> On Fri, Mar 18, 2016 at 02:43:42PM -0400, Leo Famulari wrote:
>> > Can someone with more experience take a look and apply the patch if it's
>> > okay?
>>
>> I had a look (without having much experience with the trivial build system),
>> and it looks mostly clean. However, the package installs three bash scripts
>> that start with "#!/bin/bash". This will not work on GuixSD, where only
>> /bin/sh exists. It should be patched by adding bash as an input and
>> substituting. Alternatively, you could use the gnu-build-system, delete most
>> of the phases, set #:tests? to #f and add a custom install phase; then the
>> patch-shebangs phase will do its magic.
>
> Good catch!
>
> I think using gnu-build-system is the way to go.
Here's a patch using the gnu build system:
>From 7daef2ee0fdb1aef7344da6ff0afe31efcf41cac Mon Sep 17 00:00:00 2001
From: Roel Janssen <roel@gnu.org>
Date: Tue, 3 May 2016 12:43:00 +0200
Subject: [PATCH] gnu: Add bash-tap.
* gnu/packages/bash.scm (bash-tap): New variable.
---
gnu/packages/bash.scm | 33 +++++++++++++++++++++++++++++++++
1 file changed, 33 insertions(+)
@@ -318,3 +318,36 @@ without modification.")
completion for many common commands.")
(home-page "http://bash-completion.alioth.debian.org/")
(license gpl2+)))
+
+(define-public bash-tap
+ (package
+ (name "bash-tap")
+ (version "1.0.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/illusori/bash-tap/archive/"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0qs1qi38bl3ns4mpagcawv618dsk2q1lgrbddgvs0wl3ia12cyz5"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; There is no test suite.
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure) ; There is no Makefile.
+ (delete 'build) ; There is no Makefile.
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((bin (string-append (assoc-ref outputs "out") "/bin")))
+ (install-file "bash-tap" bin)
+ (install-file "bash-tap-bootstrap" bin)
+ (install-file "bash-tap-mock" bin)))))))
+ (home-page "http://www.illusori.co.uk/projects/bash-tap/")
+ (synopsis "Bash port of a Test::More/Test::Builder-style TAP-compliant
+test library")
+ (description "Bash TAP is a TAP-compliant Test::More-style testing library
+for Bash shell scripts and functions. Along with the Test::More-style testing
+helpers it provides helper functions for mocking commands and in-process output
+capturing.")
+ (license expat)))