Commit Message
Marius Bakke <mbakke@fastmail.com> writes:
> Julien Lepiller <julien@lepiller.eu> writes:
>
>>> Could you send an updated patch to address those issues? Then we can
>>> happily apply it.
>> here is the updated patch. I let the tests be done because it doesn't
>> harm, but it does no good either, so feel free to disable them if you
>> prefer.
>
> Hello! I've gone through this package and made some improvements. I also
> managed to enable the test suite, but had to resort to strace to figure
> out what was going on (/bin/sh calls..).
Oops, here is a version that actually passes `guix lint`.
Comments
Hi Marius,
Marius Bakke <mbakke@fastmail.com> skribis:
> Marius Bakke <mbakke@fastmail.com> writes:
>
>> Julien Lepiller <julien@lepiller.eu> writes:
>>
>>>> Could you send an updated patch to address those issues? Then we can
>>>> happily apply it.
>>> here is the updated patch. I let the tests be done because it doesn't
>>> harm, but it does no good either, so feel free to disable them if you
>>> prefer.
>>
>> Hello! I've gone through this package and made some improvements. I also
>> managed to enable the test suite, but had to resort to strace to figure
>> out what was going on (/bin/sh calls..).
>
> Oops, here is a version that actually passes `guix lint`.
>
> From 83b2913549784e5d3bafd29641e314b308f7df11 Mon Sep 17 00:00:00 2001
> From: Julien Lepiller <julien@lepiller.eu>
> Date: Fri, 11 Nov 2016 15:18:29 +0100
> Subject: [PATCH] gnu: Add php.
>
> * gnu/packages/php.scm: New file.
> * gnu/local.mk (GNU_SYSTEM_MODULES): Add it.
Thanks for the update!
> + ;;"bcmath/libbcmath"
So this one is very different from ‘bc’?
> + ;;"fileinfo/libmagic" ; This is a patched version of libmagic.
Here adding a dependency on ‘file’ instead (the package that provides
libmagic) didn’t cut it, right?
> + (add-before 'check 'set-test-environment
> + (lambda _
> + ;; Without this variable, `make test' passes regardless of failures.
> + (setenv "REPORT_EXIT_STATUS" "1")
> + #t)))
> + #:test-target "test"
> + #:tests? #t))
Do you have more info as to what fails? I wouldn’t be surprised if
there were lots of issues having to do with the use of /bin/sh, host
name lookups, and other things not available in the build environment.
Could you gather more info as to what fails so that we can either fix
it, or at least convince ourselves that these are not serious issues and
document them in a comment?
Thanks Julien & Marius!
Ludo’.
From 83b2913549784e5d3bafd29641e314b308f7df11 Mon Sep 17 00:00:00 2001
From: Julien Lepiller <julien@lepiller.eu>
Date: Fri, 11 Nov 2016 15:18:29 +0100
Subject: [PATCH] gnu: Add php.
* gnu/packages/php.scm: New file.
* gnu/local.mk (GNU_SYSTEM_MODULES): Add it.
---
gnu/local.mk | 1 +
gnu/packages/php.scm | 204 +++++++++++++++++++++++++++++++++++++++++++++++++++
2 files changed, 205 insertions(+)
create mode 100644 gnu/packages/php.scm
@@ -295,6 +295,7 @@ GNU_SYSTEM_MODULES = \
%D%/packages/pem.scm \
%D%/packages/perl.scm \
%D%/packages/photo.scm \
+ %D%/packages/php.scm \
%D%/packages/pkg-config.scm \
%D%/packages/plotutils.scm \
%D%/packages/polkit.scm \
new file mode 100644
@@ -0,0 +1,204 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2016 Julien Lepiller <julien@lepiller.eu>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages php)
+ #:use-module (gnu packages)
+ #:use-module (gnu packages algebra)
+ #:use-module (gnu packages aspell)
+ #:use-module (gnu packages base)
+ #:use-module (gnu packages bison)
+ #:use-module (gnu packages compression)
+ #:use-module (gnu packages curl)
+ #:use-module (gnu packages cyrus-sasl)
+ #:use-module (gnu packages databases)
+ #:use-module (gnu packages fontutils)
+ #:use-module (gnu packages gd)
+ #:use-module (gnu packages gettext)
+ #:use-module (gnu packages glib)
+ #:use-module (gnu packages gnupg)
+ #:use-module (gnu packages image)
+ #:use-module (gnu packages multiprecision)
+ #:use-module (gnu packages openldap)
+ #:use-module (gnu packages pcre)
+ #:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages readline)
+ #:use-module (gnu packages textutils)
+ #:use-module (gnu packages tls)
+ #:use-module (gnu packages web)
+ #:use-module (gnu packages xml)
+ #:use-module (gnu packages xorg)
+ #:use-module (gnu packages zip)
+ #:use-module (guix packages)
+ #:use-module (guix download)
+ #:use-module (guix build-system gnu)
+ #:use-module ((guix licenses) #:prefix license:))
+
+(define-public php
+ (package
+ (name "php")
+ (version "7.0.13")
+ (home-page "https://secure.php.net/")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append home-page "distributions/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1gzihbpcp51jc587gs1ryn59hsnr7vf5427dmcvdimvm77wsfyrm"))
+ (modules '((guix build utils)))
+ (snippet
+ '(with-directory-excursion "ext"
+ (for-each delete-file-recursively
+ ;; Some of the bundled libraries have no proper upstream.
+ ;; Ideally we'd extract these out as separate packages:
+ ;;"mbstring/libmbfl"
+ ;;"date/lib"
+ ;;"bcmath/libbcmath"
+ ;;"fileinfo/libmagic" ; This is a patched version of libmagic.
+ '("gd/libgd"
+ "mbstring/oniguruma"
+ "pcre/pcrelib"
+ "sqlite3/libsqlite"
+ "xmlrpc/libxmlrpc"
+ "zip/lib"))))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:configure-flags
+ (let-syntax ((with (syntax-rules ()
+ ((_ option input)
+ (string-append option "="
+ (assoc-ref %build-inputs input))))))
+ (list (with "--with-bz2" "bzip2")
+ (with "--with-curl" "curl")
+ (with "--with-freetype-dir" "freetype")
+ (with "--with-gd" "gd")
+ (with "--with-gdbm" "gdbm")
+ (with "--with-gettext" "glibc") ; libintl.h
+ (with "--with-gmp" "gmp")
+ (with "--with-jpeg-dir" "libjpeg")
+ (with "--with-ldap" "openldap")
+ (with "--with-ldap-sasl" "cyrus-sasl")
+ (with "--with-libzip" "zip")
+ (with "--with-libxml-dir" "libxml2")
+ (with "--with-onig" "oniguruma")
+ (with "--with-pcre-dir" "pcre")
+ (with "--with-pcre-regex" "pcre")
+ (with "--with-pdo-pgsql" "postgresql")
+ (with "--with-pdo-sqlite" "sqlite")
+ (with "--with-pgsql" "postgresql")
+ (with "--with-png-dir" "libpng")
+ ;; PHP’s Pspell extension, while retaining its current name,
+ ;; now uses the Aspell library.
+ (with "--with-pspell" "aspell")
+ (with "--with-readline" "readline")
+ (with "--with-sqlite3" "sqlite")
+ (with "--with-tidy" "tidy")
+ (with "--with-webp-dir" "libwebp")
+ (with "--with-xpm-dir" "libxpm")
+ (with "--with-xsl" "libxslt")
+ (with "--with-zlib-dir" "zlib")
+ ;; We could add "--with-snmp", but it requires netsnmp that
+ ;; we don't have a package for. It is used to build the snmp
+ ;; extension of php.
+ "--with-iconv"
+ "--with-openssl"
+ "--with-pdo-mysql"
+ "--with-zlib"
+ "--enable-calendar"
+ "--enable-dba=shared"
+ "--enable-exif"
+ "--enable-flatfile"
+ "--enable-fpm"
+ "--enable-ftp"
+ "--enable-inifile"
+ "--enable-mbstring"
+ "--enable-pcntl"
+ "--enable-sockets"
+ "--enable-threads"))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'do-not-record-build-flags
+ (lambda _
+ ;; Prevent configure flags from being stored and causing
+ ;; unnecessary runtime dependencies.
+ ;; FIXME: Guile throws decoding error on this ISO-8859 file.
+ ;(substitute* "main/build-defs.h.in"
+ ; (("@CONFIGURE_COMMAND@") "(omitted)"))
+ (substitute* "scripts/php-config.in"
+ (("@CONFIGURE_OPTIONS@") "")
+ (("@PHP_LDFLAGS@") ""))
+ #t))
+ (add-before 'build 'patch-/bin/sh
+ (lambda _
+ (substitute* '("run-tests.php" "ext/standard/proc_open.c")
+ (("/bin/sh") (which "sh")))
+ #t))
+ (add-before 'check 'set-test-environment
+ (lambda _
+ ;; Without this variable, `make test' passes regardless of failures.
+ (setenv "REPORT_EXIT_STATUS" "1")
+ #t)))
+ #:test-target "test"
+ #:tests? #t))
+ (inputs
+ `(("aspell" ,aspell)
+ ("bzip2" ,bzip2)
+ ("curl" ,curl)
+ ("cyrus-sasl" ,cyrus-sasl)
+ ("freetype" ,freetype)
+ ("gd" ,gd)
+ ("gdbm" ,gdbm)
+ ("glibc" ,glibc)
+ ("gmp" ,gmp)
+ ("libgcrypt" ,libgcrypt)
+ ("libjpeg" ,libjpeg)
+ ("libpng" ,libpng)
+ ("libwebp" ,libwebp)
+ ("libxml2" ,libxml2)
+ ("libxpm" ,libxpm)
+ ("libxslt" ,libxslt)
+ ("libx11" ,libx11)
+ ("oniguruma" ,oniguruma)
+ ("openldap" ,openldap)
+ ("openssl" ,openssl)
+ ("pcre" ,pcre)
+ ("postgresql" ,postgresql)
+ ("readline" ,readline)
+ ("sqlite" ,sqlite)
+ ("tidy" ,tidy)
+ ("zip" ,zip)
+ ("zlib" ,zlib)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("bison" ,bison)
+ ("intltool" ,intltool)
+ ("libxml2" ,libxml2))) ; for xml2-config
+ (synopsis "PHP programming language")
+ (description
+ "PHP (PHP Hypertext Processor) is a server-side (CGI) scripting
+language designed primarily for web development but is also used as
+a general-purpose programming language. PHP code may be embedded into
+HTML code, or it can be used in combination with various web template
+systems, web content management systems and web frameworks." )
+ (license (list
+ (license:non-copyleft "file://LICENSE") ; The PHP license.
+ (license:non-copyleft "file://Zend/LICENSE") ; The Zend license.
+ license:lgpl2.1 ; ext/mbstring/libmbfl
+ license:lgpl2.1+ ; ext/bcmath/libbcmath
+ license:bsd-2 ; ext/fileinfo/libmagic
+ license:expat)))) ; ext/date/lib
--
2.10.2