Commit Message
Ludovic Courtès <ludo@gnu.org> writes:
> Hi Marius,
>
> Marius Bakke <mbakke@fastmail.com> skribis:
>
>> Ludovic Courtès <ludo@gnu.org> writes:
>>
>>>>>> From 940c03c7dcddec019e27f6eb1470aeab4db57799 Mon Sep 17 00:00:00 2001
>>>>>> From: Marius Bakke <mbakke@fastmail.com>
>>>>>> Date: Thu, 20 Oct 2016 17:26:52 +0100
>>>>>> Subject: [PATCH] gnu: Add grub-efi.
>>>>>>
>>>>>> * gnu/packages/grub.scm (grub-efi): New variable.
>>>>>
>>>>> [...]
>>>>>
>>>>>> + (name "grub-efi")
>>>>>> + (synopsis (string-append (package-synopsis grub) " (UEFI version)"))
>>>>>
>>>>> Please use a literal string for ‘synopsis’; use of ‘string-append’ like
>>>>> this prevents i18n.
>>>>>
>>>>>> + `(#:tests? #f ; FIXME: 40 failures, 24 skipped, 17 passed.
>>>>>
>>>>> It would be good to investigate, especially if the tests pass in the
>>>>> ‘grub’ package.
>>>>>
>>>>> Also, what’s the rationale for making ‘grub-efi’ separate instead of
>>>>> incorporating the changes in ‘grub’ proper? Are there issues around the
>>>>> portability of ‘efibootmgr’, or an increased closure size?
>>>>
>>>> This is a good point. The only difference with "--with-platform=efi" is
>>>> that another directory is created in place of the i386-pc directory. It
>>>> is perfectly possible to build multiple platforms and copying the
>>>> platform-specific stuff to $out/lib -- grub will pick the correct
>>>> platform at runtime. This is what the Gentoo ebuild does.
>>>
>>> Are you saying that a GRUB compiled with UEFI support will no longer
>>> work out-of-the-box on non-UEFI machines, unless platform-specific stuff
>>> is moved like you suggest?
>>
>> Ha, no, it was just a long-winded and intoxicated way of saying what you
>> proposed should work fine. :)
>
> It turns out I have an immediate need ;-), so I pushed this as commit
> 3eee16130d858ae96510ec1c7d38d31290de2699. Let me know if that doesn’t
> seem right!
>
> Now there are things I didn’t quite get. Apparently you’re supposed to
> have a /boot/efi as a vfat partition, and ‘grub-install’ is supposed to
> detect it and install the EFI stuff, or so I thought (info "(grub)
> Installing GRUB using grub-install").
>
> However, ‘grub-install’ still seems to be installing for “i386-pc”
> instead of EFI.
>
> What am I missing?
For anyone following along at home, I've attached the patches I'm using
for UEFI GuixSD. The latter two probably won't work properly on a
non-UEFI system, needs testing.
Comments
> For anyone following along at home, I've attached the patches I'm using
> for UEFI GuixSD. The latter two probably won't work properly on a
> non-UEFI system, needs testing.
Never mind the last part, 'guix system vm-image' works fine with these
patches.
From 0a7c923618e8323c684ac8328ea6aa498b8cb13c Mon Sep 17 00:00:00 2001
From: Marius Bakke <mbakke@fastmail.com>
Date: Thu, 3 Nov 2016 09:58:34 +0000
Subject: [PATCH 1/5] linux-initrd: Support FAT filesystems.
* gnu/system/linux-initrd.scm (base-initrd): When a FAT filesystem is
present: Add fatfsck/static in 'helper-packages'; and add nls_iso8859-1
in 'linux-modules'.
---
gnu/system/linux-initrd.scm | 9 +++++++++
1 file changed, 9 insertions(+)
@@ -29,6 +29,7 @@
#:select (derivation->output-path))
#:use-module (guix modules)
#:use-module (gnu packages compression)
+ #:use-module (gnu packages disk)
#:use-module (gnu packages linux)
#:use-module (gnu packages guile)
#:use-module ((gnu packages make-bootstrap)
@@ -193,6 +194,9 @@ loaded at boot time in the order in which they appear."
,@(if (find (file-system-type-predicate "9p") file-systems)
virtio-9p-modules
'())
+ ,@(if (find (file-system-type-predicate "vfat") file-systems)
+ '("nls_iso8859-1")
+ '())
,@(if volatile-root?
'("fuse")
'())
@@ -205,6 +209,11 @@ loaded at boot time in the order in which they appear."
file-systems)
(list e2fsck/static)
'())
+ ,@(if (find (lambda (fs)
+ (string-suffix? "fat" (file-system-type fs)))
+ file-systems)
+ (list fatfsck/static)
+ '())
,@(if volatile-root?
(list unionfs-fuse/static)
'())))
--
2.11.0
From fbddad884b553b6a70ae4da0ee47f29599958704 Mon Sep 17 00:00:00 2001
From: Marius Bakke <mbakke@fastmail.com>
Date: Thu, 3 Nov 2016 11:08:57 +0000
Subject: [PATCH 2/5] file-systems: Suppress fsck status completion bar.
* gnu/build/file-systems.scm (check-file-system): Drop "-C" argument
from fsck for compatibility with other fscks.
---
gnu/build/file-systems.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
@@ -415,7 +415,7 @@ the following:
(define fsck
(string-append "fsck." type))
- (let ((status (system* fsck "-v" "-p" "-C" "0" device)))
+ (let ((status (system* fsck "-v" "-p" device)))
(match (status:exit-val status)
(0
#t)
--
2.11.0
From 10d696468c3c4cb64980fa1131969e9bb42536c5 Mon Sep 17 00:00:00 2001
From: Marius Bakke <mbakke@fastmail.com>
Date: Thu, 20 Oct 2016 17:26:52 +0100
Subject: [PATCH 3/5] gnu: Add grub-efi.
* gnu/packages/grub.scm (grub-efi): New variable.
---
gnu/packages/grub.scm | 11 +++++++++++
1 file changed, 11 insertions(+)
@@ -173,3 +173,14 @@ on the same computer; upon booting the computer, the user is presented with a
menu to select one of the installed operating systems.")
(license gpl3+)
(properties '((cpe-name . "grub2")))))
+
+(define-public grub-efi
+ (package
+ (inherit grub)
+ (name "grub-efi")
+ (synopsis "GRand Unified Boot loader (UEFI variant)")
+ (arguments
+ `(#:tests? #f ; FIXME: 40 failures, 24 skipped, 17 passed.
+ ,@(substitute-keyword-arguments (package-arguments grub)
+ ((#:configure-flags flags) `(cons* "--with-platform=efi"
+ ,flags)))))))
--
2.11.0
From 1bac0d81be36a3d8c0f206acbfd16e2b61a792ac Mon Sep 17 00:00:00 2001
From: Marius Bakke <mbakke@fastmail.com>
Date: Sun, 6 Nov 2016 17:26:06 +0000
Subject: [PATCH 4/5] build: Make grub-install command UEFI aware.
* gnu/build/install.scm (install-grub): Extend grub-install command with
'--bootloader-id' and '--efi-directory'.
---
gnu/build/install.scm | 3 +++
1 file changed, 3 insertions(+)
@@ -54,6 +54,9 @@ GC'd."
(unless (zero? (system* "grub-install" "--no-floppy"
"--boot-directory"
(string-append mount-point "/boot")
+ "--bootloader-id=GNU"
+ "--efi-directory"
+ (string-append mount-point "/boot")
device))
(error "failed to install GRUB")))
--
2.11.0
From 117859a063e99b8726c205f5d454e306a241e885 Mon Sep 17 00:00:00 2001
From: Marius Bakke <mbakke@fastmail.com>
Date: Mon, 7 Nov 2016 12:24:01 +0000
Subject: [PATCH 5/5] system: Load efi modules in grub.cfg.
* gnu/system/grub.scm (eye-candy): Load 'efi_gop' and 'efi_uga' grub modules.
---
gnu/system/grub.scm | 2 ++
1 file changed, 2 insertions(+)
@@ -183,6 +183,8 @@ system string---e.g., \"x86_64-linux\"."
(if (string-match "^(x86_64|i[3-6]86)-" system)
"
# Leave 'gfxmode' to 'auto'.
+ insmod efi_gop
+ insmod efi_uga
insmod vbe
insmod vga
insmod video_bochs
--
2.11.0