[1/1] gnu: python-libxml2: Don't use as replacement for libxml2.

Message ID 62ac43add157952dca3a1a478b774b65d859b31c.1464146347.git.leo@famulari.name
State New
Headers

Commit Message

Leo Famulari May 25, 2016, 3:24 a.m. UTC
  This is a followup to commit 493e9a5a8f613764cfa396c33ee6cb381b0dbbef.

* gnu/packages/xml.scm (python-libxml2, python2-libxml2)[replacement]:
New field.
---
 gnu/packages/xml.scm | 1 +
 1 file changed, 1 insertion(+)
  

Comments

Mark H Weaver May 25, 2016, 5:55 p.m. UTC | #1
Hi,

Leo Famulari <leo@famulari.name> writes:

> This is a followup to commit 493e9a5a8f613764cfa396c33ee6cb381b0dbbef.
>
> * gnu/packages/xml.scm (python-libxml2, python2-libxml2)[replacement]:
> New field.
> ---
>  gnu/packages/xml.scm | 1 +
>  1 file changed, 1 insertion(+)
>
> diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
> index 96bb8b7..782e356 100644
> --- a/gnu/packages/xml.scm
> +++ b/gnu/packages/xml.scm
> @@ -115,6 +115,7 @@ project (but it is usable outside of the Gnome platform).")
>  (define-public python-libxml2
>    (package (inherit libxml2)
>      (name "python-libxml2")
> +    (replacement #f)
>      (build-system python-build-system)
>      (arguments
>       `(;; XXX: Tests are specified in 'Makefile.am', but not in 'setup.py'.

I noticed the same problem, and pushed the same fix, before seeing this
message.  Thanks anyway!

      Mark
  

Patch

diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index 96bb8b7..782e356 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -115,6 +115,7 @@  project (but it is usable outside of the Gnome platform).")
 (define-public python-libxml2
   (package (inherit libxml2)
     (name "python-libxml2")
+    (replacement #f)
     (build-system python-build-system)
     (arguments
      `(;; XXX: Tests are specified in 'Makefile.am', but not in 'setup.py'.