[02/10] gnu: Update python-unittest2 to 0.6.0

Message ID 572BF347.9080301@gmail.com
State New
Headers

Commit Message

Cyril Roelandt May 6, 2016, 1:28 a.m. UTC
  On 04/30/2016 11:33 PM, Leo Famulari wrote:
> As with python-cmd2, could you if setuptools is required for the
> python-3 variant?
> 

So, I applied the following patch:


   (package


I can still build python-unittest2 and python-barbicanclient:

$ ./pre-inst-env guix build python-unittest2
/gnu/store/kh4nbzvqv9ic535xls92q8j6p6iz30kk-python-unittest2-0.6.0
$ ./pre-inst-env guix build python-barbicanclient
/gnu/store/n3kas9l1ffcf84gdbx1sswzrm4cl93n6-python-barbicanclient-4.0.1

I can still build python2-unittest2:

$ ./pre-inst-env guix build python2-unittest2
/gnu/store/ld9l5y5hxs19d15babphp7mv1kxsak55-python2-unittest2-0.6.0

But I can no longer build python2-barbicanclient:

http://paste.debian.net/682000/

>> > -       #:tests? #f)))) ; no setup.py test command
> Disabling two tests is an improvment over this! Did you find anyone else
> on the net having trouble with these two tests?

Not really, I was quite happy with enabling most of them for Python2 and
did not look any further, since my main goal was packaging
python-barbicanclient.

Cyril.
  

Comments

Leo Famulari May 6, 2016, 6:49 p.m. UTC | #1
On Fri, May 06, 2016 at 03:28:39AM +0200, Cyril Roelandt wrote:
> On 04/30/2016 11:33 PM, Leo Famulari wrote:
> > As with python-cmd2, could you if setuptools is required for the
> > python-3 variant?
> > 
> 
> So, I applied the following patch:
> 
> 
> --- a/gnu/packages/python.scm
> +++ b/gnu/packages/python.scm
> @@ -1520,8 +1520,7 @@ matching them against a list of media-ranges.")
>      (build-system python-build-system)
>      (propagated-inputs
>       `(("python-six" ,python-six)))
> -    (inputs
> -     `(("python-setuptools" ,python-setuptools)))
> +    ;(inputs `(("python-setuptools" ,python-setuptools)))
>      (home-page "http://pypi.python.org/pypi/unittest2")
>      (synopsis "Python unit testing library")
>      (description
> @@ -1530,7 +1529,12 @@ standard library.")
>      (license psfl)))

I think you forgot to add a line like this one to the python-3 variant's
definition:

   (properties `((python2-variant . ,(delay python2-unittest2))))

Can you check if everything works when you do that?
  

Patch

--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -1520,8 +1520,7 @@  matching them against a list of media-ranges.")
     (build-system python-build-system)
     (propagated-inputs
      `(("python-six" ,python-six)))
-    (inputs
-     `(("python-setuptools" ,python-setuptools)))
+    ;(inputs `(("python-setuptools" ,python-setuptools)))
     (home-page "http://pypi.python.org/pypi/unittest2")
     (synopsis "Python unit testing library")
     (description
@@ -1530,7 +1529,12 @@  standard library.")
     (license psfl)))

 (define-public python2-unittest2
-  (package-with-python2 python-unittest2))
+  ;(package-with-python2 python-unittest2))
+  (let ((base (package-with-python2 (strip-python2-variant
python-unittest2))))
+    (package
+      (inherit base)
+      (native-inputs `(("python2-setuptools" ,python2-setuptools)
+                       ,@(package-native-inputs base))))))

 (define-public python-py