gnu: hurd: Add hurd-core-headers package.

Message ID 5604a36e-bd17-19f9-da9b-dd5cb7b896ed@gmail.com
State New
Headers

Commit Message

Manolis Ragkousis May 24, 2016, 6 p.m. UTC
  Hello everyone,

This patch already exists in wip-hurd, but this is a modified version
for master. I changed the name to hurd-core-headers instead of
hurd-kernel-headers because the old name implied that the Hurd was a
kernel, which is not, and we should avoid confusion.

If you are okay with it, I will push it to master.

Manolis
  

Comments

Ludovic Courtès May 25, 2016, 9:56 p.m. UTC | #1
Manolis Ragkousis <manolis837@gmail.com> skribis:

> From 00e9667898fbe8d81bc2ad374750de8f85e801af Mon Sep 17 00:00:00 2001
> From: Manolis Ragkousis <manolis837@gmail.com>
> Date: Tue, 24 May 2016 20:42:59 +0300
> Subject: [PATCH] gnu: hurd: Add hurd-core-headers package.
>
> * gnu/packages/hurd.scm (hurd-core-headers): New variable.

[...]

> +    (inputs `(("gnumach-headers" ,gnumach-headers)
> +              ("hurd-headers" ,hurd-headers)
> +              ("hurd-minimal" ,hurd-minimal)))
> +    (synopsis "Union of the Hurd headers and libs")

s/libs/libraries/

But it’s only libihash and perhaps libstore, right?  It’s a bit
surprising to find them in a “headers” package.

> +    (description
> +     "A union of the Mach and Hurd headers and the Hurd-minimal package
         ^
“This package contains the union…”

> +which are needed for both glibc and gcc.")

s/gcc/GCC/

OK for master with these changes!

Thanks,
Ludo’.
  

Patch

From 00e9667898fbe8d81bc2ad374750de8f85e801af Mon Sep 17 00:00:00 2001
From: Manolis Ragkousis <manolis837@gmail.com>
Date: Tue, 24 May 2016 20:42:59 +0300
Subject: [PATCH] gnu: hurd: Add hurd-core-headers package.

* gnu/packages/hurd.scm (hurd-core-headers): New variable.
---
 gnu/packages/hurd.scm | 28 +++++++++++++++++++++++++++-
 1 file changed, 27 insertions(+), 1 deletion(-)

diff --git a/gnu/packages/hurd.scm b/gnu/packages/hurd.scm
index 7a0a158..8a4d0a3 100644
--- a/gnu/packages/hurd.scm
+++ b/gnu/packages/hurd.scm
@@ -1,5 +1,5 @@ 
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2014, 2015 Manolis Fragkiskos Ragkousis <manolis837@gmail.com>
+;;; Copyright © 2014, 2015, 2016 Manolis Fragkiskos Ragkousis <manolis837@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -22,6 +22,7 @@ 
   #:use-module (guix packages)
   #:use-module (gnu packages)
   #:use-module (guix build-system gnu)
+  #:use-module (guix build-system trivial)
   #:use-module (gnu packages flex)
   #:use-module (gnu packages bison)
   #:use-module (gnu packages perl)
@@ -185,3 +186,28 @@  Library and other user programs.")
      "This package provides libihash, needed to build the GNU C
 Library for GNU/Hurd.")
     (license gpl2+)))
+
+(define-public hurd-core-headers
+  (package
+    (name "hurd-core-headers")
+    (version (package-version hurd-headers))
+    (source #f)
+    (build-system trivial-build-system)
+    (arguments
+     '(#:modules ((guix build union))
+       #:builder (begin
+                   (use-modules (ice-9 match)
+                                (guix build union))
+                   (match %build-inputs
+                     (((names . directories) ...)
+                      (union-build (assoc-ref %outputs "out")
+                                   directories))))))
+    (inputs `(("gnumach-headers" ,gnumach-headers)
+              ("hurd-headers" ,hurd-headers)
+              ("hurd-minimal" ,hurd-minimal)))
+    (synopsis "Union of the Hurd headers and libs")
+    (description
+     "A union of the Mach and Hurd headers and the Hurd-minimal package
+which are needed for both glibc and gcc.")
+    (home-page (package-home-page hurd-headers))
+    (license (package-license hurd-headers))))
-- 
2.8.2