Commit Message
updated package.
Thanks for your tips.
> I also noticed a couple of things:
>
> * In June 2016 version 2.2.9 has been released. It is not available on
> sourceforge but on their servers at
>
> http://www.bennewitz.com/bluefish/stable/source/bluefish-2.2.9.tar.gz
>
> I verified the signature and computed this hash for the tarball:
> 1vnl6raxbvc4hacg3pr6sqyjh707d304dhk5nyhlp7m0m1y3j756
>
> * The description has a couple of errors. Here’s a corrected version:
>
> "Bluefish is an editor targeted towards programmers and web
> developers,
> with many options to write web sites, scripts and other code.
> Bluefish supports many programming and markup languages."
>
> * The license is GPLv3+ because the license headers contain the phrases
> “either version 3 of the License, or (at your option) any later
> version”
Comments
rennes@openmailbox.org writes:
> updated package.
Thanks, but I still cannot seem to apply it to master. Was this rebased
on top of current master?
~~ Ricardo
On 2016-10-09 16:04, Ricardo Wurmus wrote:
> rennes@openmailbox.org writes:
>
>> updated package.
>
> Thanks, but I still cannot seem to apply it to master. Was this
> rebased
> on top of current master?
>
> ~~ Ricardo
I first make the patch for gucharmap and later bluefish, gucharmap is
required for bluefish.
Am 09.10.2016 um 23:20 schrieb rennes@openmailbox.org:
>> Thanks, but I still cannot seem to apply it to master. Was this rebased
>> on top of current master?
>>
>> ~~ Ricardo
>
> I first make the patch for gucharmap and later bluefish, gucharmap is
> required for bluefish.
>
Ricado means: You should
git checkout master
git pull
git checkout your-branch-with-bluefish
git rebase master
From c0f3fc054bbe3431eed115eba8bf8bde019f19d9 Mon Sep 17 00:00:00 2001
From: Rene Saavedra <rennes@openmailbox.org>
Date: Sun, 9 Oct 2016 15:14:10 -0500
Subject: [PATCH 2/2] gnu: Add bluefish.
* gnu/packages/gnome.scm (bluefish): New variable.
---
gnu/packages/gnome.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)
@@ -5576,3 +5576,34 @@ characters and categories for the installed fonts, and to examine their
detailed properties. It is an easy way to find the character you might
only know by its Unicode name or code point.")
(license license:gpl3+)))
+
+(define-public bluefish
+ (package
+ (name "bluefish")
+ (version "2.2.9")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://www.bennewitz.com/bluefish/stable/source/"
+ name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1vnl6raxbvc4hacg3pr6sqyjh707d304dhk5nyhlp7m0m1y3j756"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("desktop-file-utils" ,desktop-file-utils)
+ ("intltool" ,intltool)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("enchant" ,enchant)
+ ("gtk+" ,gtk+)
+ ("python" ,python-2)
+ ("xmllint" ,libxml2)
+ ("gucharmap" ,gucharmap)))
+ (home-page "http://bluefish.openoffice.nl")
+ (synopsis "Web development studio")
+ (description
+ "Bluefish is an editor targeted towards programmers and web developers,
+with many options to write web sites, scripts and other code.
+Bluefish supports many programming and markup languages.")
+ (license license:gpl3+)))
--
2.10.0