[2/2] gnu: utox: Update to 0.11.0.
Commit Message
* gnu/packages/messaging.scm (utox): Update to 0.11.0.
[source]: Update source uri.
[build-system]: Change to cmake-build-system.
[arguments]: Remove previous content and disable tests,
add two new phases.
[inputs]: Remove libtoxcore, add c-toxcore.
[native-inputs]: Remove it.
---
gnu/packages/messaging.scm | 32 ++++++++++++++++++++------------
1 file changed, 20 insertions(+), 12 deletions(-)
Comments
On Thu, Dec 15, 2016 at 07:14:15PM +0000, ng0 wrote:
> * gnu/packages/messaging.scm (utox): Update to 0.11.0.
> [source]: Update source uri.
> [build-system]: Change to cmake-build-system.
> [arguments]: Remove previous content and disable tests,
> add two new phases.
> [inputs]: Remove libtoxcore, add c-toxcore.
> [native-inputs]: Remove it.
Overall LGTM, but can you give some more information about the changed
source location?
> - (uri (string-append "https://github.com/GrayHatter/uTox/archive/v"
> + (uri (string-append "https://github.com/uTox/uTox/archive/v"
> version ".tar.gz"))
Leo Famulari <leo@famulari.name> writes:
> On Thu, Dec 15, 2016 at 07:14:15PM +0000, ng0 wrote:
>> * gnu/packages/messaging.scm (utox): Update to 0.11.0.
>> [source]: Update source uri.
>> [build-system]: Change to cmake-build-system.
>> [arguments]: Remove previous content and disable tests,
>> add two new phases.
>> [inputs]: Remove libtoxcore, add c-toxcore.
>> [native-inputs]: Remove it.
>
> Overall LGTM, but can you give some more information about the changed
> source location?
GrayHatter moved uTox to its own organization I assume? What
exactly do you mean by giving more information? I don't really
use github and therefore I can not ask people, just guess. And
the more up to date code is in the uTox namespace where the
previous developer/namespace, GrayHatter commits to aswell.
>> - (uri (string-append "https://github.com/GrayHatter/uTox/archive/v"
>> + (uri (string-append "https://github.com/uTox/uTox/archive/v"
>> version ".tar.gz"))
>
@@ -34,6 +34,7 @@
#:use-module (guix build-system glib-or-gtk)
#:use-module (guix build-system python)
#:use-module (guix build-system perl)
+ #:use-module (guix build-system cmake)
#:use-module (gnu packages)
#:use-module (gnu packages aidc)
#:use-module (gnu packages autotools)
@@ -662,40 +663,47 @@ protocols.")
(define-public utox
(package
(name "utox")
- (version "0.9.8")
+ (version "0.11.0")
(source
(origin
(method url-fetch)
- (uri (string-append "https://github.com/GrayHatter/uTox/archive/v"
+ (uri (string-append "https://github.com/uTox/uTox/archive/v"
version ".tar.gz"))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "13hfqbwzcgvfbvf9yjm62aqsvxnpqppb50c88sys43m7022yqcsy"))))
- (build-system gnu-build-system)
+ "15s4iwjk1s0kihjqn0f07c9618clbphpr827mds3xddkiwnjz37v"))))
+ (build-system cmake-build-system)
(arguments
- '(#:make-flags (list (string-append "PREFIX=" %output)
- "CC=gcc")
- #:tests? #f ; No tests
+ '(#:tests? #f ; No test phase.
#:phases
(modify-phases %standard-phases
- ;; No configure script
- (delete 'configure))))
+ (add-after 'unpack 'fix-freetype-include
+ (lambda _
+ (substitute* "CMakeLists.txt"
+ (("/usr/include/freetype2")
+ (string-append (assoc-ref %build-inputs "freetype")
+ "/include/freetype2")))))
+ (add-before 'install 'patch-cmake-find-utox
+ (lambda _
+ (substitute* "../build/cmake_install.cmake"
+ (("/uTox-0.11.0/utox")
+ "/build/utox")))))))
(inputs
+ ;; TODO: Fix the filechoser dialogue, which input
+ ;; does it need?
`(("dbus" ,dbus)
("filteraudio" ,filteraudio)
("fontconfig" ,fontconfig)
("freetype" ,freetype)
("libsodium" ,libsodium)
- ("libtoxcore" ,libtoxcore)
+ ("c-toxcore" ,c-toxcore)
("libvpx" ,libvpx)
("libx11" ,libx11)
("libxext" ,libxext)
("libxrender" ,libxrender)
("openal" ,openal)
("v4l-utils" ,v4l-utils)))
- (native-inputs
- `(("pkg-config" ,pkg-config)))
(synopsis "Lightweight Tox client")
(description "A lightweight Tox client. Tox is a distributed and secure
instant messenger with audio and video chat capabilities.")