[05/11] gnu: Add python-pygit2.

Message ID 20161211181237.24485-6-ng0@libertad.pw
State New
Headers

Commit Message

ng0 Dec. 11, 2016, 6:12 p.m. UTC
  * gnu/packages/python.scm (python-pygit2): New variable.
---
 gnu/packages/python.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)
  

Comments

Leo Famulari Dec. 13, 2016, 10:47 p.m. UTC | #1
On Tue, Dec 13, 2016 at 10:34:03AM +0100, Marius Bakke wrote:
> Sounds like we're going down the same road. I've started a branch with
> the earlier patch and a few other fixes. Is it ok to overwrite the
> existing 'python-updates' branch on Savannah?

I'm going to delete that old branch tomorrow if there are no objections.
I started it before I knew the magnitude of the work required, and I
think it will be easier to start from scratch.
  

Patch

diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 2a49a060b..32f83deb4 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -3376,6 +3376,36 @@  association studies (GWAS) on extremely large data sets.")
 (define-public python2-numpy
   (package-with-python2 python-numpy))
 
+(define-public python-pygit2
+  (package
+    (name "python-pygit2")
+    (version "0.24.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://github.com/libgit2/"
+                           "pygit2/archive/v" version ".tar.gz"))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "1j7zkz2bsn4wqmkg1zkxb3r00xx28rkz9jdwcsikcl4ffa298xwa"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("python-six" ,python-six)
+       ("python-cffi" ,python-cffi)
+       ("libgit2" ,libgit2)
+       ("python-tox" ,python-tox)))
+    (home-page "http://github.com/libgit2/pygit2")
+    (synopsis "Python bindings for libgit2")
+    (description
+     "Pygit2 is a set of Python bindings to the libgit2
+shared library, libgit2 implements Git plumbing.")
+    ;; GPL2.0 only, with linking exception.
+    (license license:gpl2)))
+
+(define-public python2-pygit2
+  (package-with-python2 python-pygit2))
+
 (define-public python-pyparsing
   (package
     (name "python-pyparsing")