gnu: psyclpc: Downgrade to 27f21a3bf0d140f0d2680c695e8df229b46a814b.

Message ID 20161201191312.11951-2-ng0@libertad.pw
State New
Headers

Commit Message

ng0 Dec. 1, 2016, 7:13 p.m. UTC
  * gnu/packages/messaging.scm (psyclpc): Downgrade it.

The bundled pcre and reproducible build is introduced in an commit
which broke xmpp functionality with psyclpc in psyced, therefore we
wait for an fix upstream in psyced and then update psyclpc again
when psyced is added.
---
 gnu/packages/messaging.scm | 14 ++++++++------
 1 file changed, 8 insertions(+), 6 deletions(-)
  

Comments

ng0 Dec. 3, 2016, 5:13 p.m. UTC | #1
The correct spelling of:
gnu: psyclpc: Downgrade to 27f21a3bf0d140f0d2680c695e8df229b46a814b.

would be:
gnu: psyclpc: Downgrade to  20160821-3.27f21a3.

Can the person who applies this patch change it?
Thanks!

ng0 <ng0@libertad.pw> writes:

> * gnu/packages/messaging.scm (psyclpc): Downgrade it.
>
> The bundled pcre and reproducible build is introduced in an commit
> which broke xmpp functionality with psyclpc in psyced, therefore we
> wait for an fix upstream in psyced and then update psyclpc again
> when psyced is added.
> ---
>  gnu/packages/messaging.scm | 14 ++++++++------
>  1 file changed, 8 insertions(+), 6 deletions(-)
>
> diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
> index 8660915bb..2b80589f0 100644
> --- a/gnu/packages/messaging.scm
> +++ b/gnu/packages/messaging.scm
> @@ -980,10 +980,13 @@ including psyced.")
>      (synopsis "PSYC library in C")
>      (license license:agpl3+)))
>  
> -;; This commit removes the historic bundled pcre and makes psyclpc reproducible.
> +;; The bundled pcre and reproducible build is introduced in an commit
> +;; which broke xmpp functionality with psyclpc in psyced, therefore we
> +;; wait for an upstream fix in psyced and then update psyclpc again
> +;; when psyced is added.
>  (define-public psyclpc
> -  (let* ((commit "61cf9aa81297085e5c40170fd01221c752f8deba")
> -         (revision "2"))
> +  (let* ((commit "27f21a3bf0d140f0d2680c695e8df229b46a814b")
> +         (revision "3"))
>    (package
>      (name "psyclpc")
>      (version (string-append "20160821-" revision "." (string-take commit 7)))
> @@ -995,7 +998,7 @@ including psyced.")
>                (file-name (string-append name "-" version "-checkout"))
>                (sha256
>                 (base32
> -                "1viwqymbhn3cwvx0zl58rlzl5gw47zxn0ldg2nbi55ghm5zxl1z5"))))
> +                "1m17xyixbh6wfwk727h3cfjmyfplcgvwbgh12kap1856xiqh99c5"))))
>      (build-system gnu-build-system)
>      (arguments
>       `(#:tests? #f ; There are no tests/checks.
> @@ -1034,8 +1037,7 @@ including psyced.")
>         #:make-flags (list "install-all")))
>      (inputs
>       `(("zlib" ,zlib)
> -       ("openssl" ,openssl)
> -       ("pcre" ,pcre)))
> +       ("openssl" ,openssl)))
>      (native-inputs
>       `(("pkg-config" ,pkg-config)
>         ("bison" ,bison)
> -- 
> 2.11.0
>
>
  
ng0 Dec. 3, 2016, 6:22 p.m. UTC | #2
Okay, correction: please do not apply this downgrade. The reasons
for this are as follows (tl;dr: fix will be in psyced, which is
currently not in master and psyclpc is behaving as it should):

ng0          I don't want the software in master which is known to have a problem, but I added the commit before I was remember that this problem exists (lack of issue tracker for this application, i have
             addressed it and hope it gets added soon to our issue tracker), so it builds, yeah, but it has problems. the only known problem exists in combination with psyced, which depends on psyclpc at runtime.
             if you were to use
ng0          this version you'd have no xmpp functionality. it is possible that there are no other problems at all. I've pointed out that we (upstream) need to write tests for both applications which can prevent
             relying just on "you know the code".
ng0          so if you think it's okay to keep the package as it is, i'm okay with it
ng0          from upstream perspective I found the software broken and want to revert until it (the way pcre is used) is fixed.
ng0          eh downgrade
ng0          sorry, terms
…
ng0          the fix for this problem will be in psyced, not psyclpc
ng0          so theoretically psyclpc is good
…
ng0          ok. I thought about it.. there's no harm in keeping that psyclpc version. and I'll ask for a new release to be made as soon as psyced is fixed. i think the preference was to release both together
ng0          i'll put a summary of what I've written as an reply to the thread so it doesn't get applied

ng0 <ng0@libertad.pw> writes:

> The correct spelling of:
> gnu: psyclpc: Downgrade to 27f21a3bf0d140f0d2680c695e8df229b46a814b.
>
> would be:
> gnu: psyclpc: Downgrade to  20160821-3.27f21a3.
>
> Can the person who applies this patch change it?
> Thanks!
>
> ng0 <ng0@libertad.pw> writes:
>
>> * gnu/packages/messaging.scm (psyclpc): Downgrade it.
>>
>> The bundled pcre and reproducible build is introduced in an commit
>> which broke xmpp functionality with psyclpc in psyced, therefore we
>> wait for an fix upstream in psyced and then update psyclpc again
>> when psyced is added.
>> ---
>>  gnu/packages/messaging.scm | 14 ++++++++------
>>  1 file changed, 8 insertions(+), 6 deletions(-)
>>
>> diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
>> index 8660915bb..2b80589f0 100644
>> --- a/gnu/packages/messaging.scm
>> +++ b/gnu/packages/messaging.scm
>> @@ -980,10 +980,13 @@ including psyced.")
>>      (synopsis "PSYC library in C")
>>      (license license:agpl3+)))
>>  
>> -;; This commit removes the historic bundled pcre and makes psyclpc reproducible.
>> +;; The bundled pcre and reproducible build is introduced in an commit
>> +;; which broke xmpp functionality with psyclpc in psyced, therefore we
>> +;; wait for an upstream fix in psyced and then update psyclpc again
>> +;; when psyced is added.
>>  (define-public psyclpc
>> -  (let* ((commit "61cf9aa81297085e5c40170fd01221c752f8deba")
>> -         (revision "2"))
>> +  (let* ((commit "27f21a3bf0d140f0d2680c695e8df229b46a814b")
>> +         (revision "3"))
>>    (package
>>      (name "psyclpc")
>>      (version (string-append "20160821-" revision "." (string-take commit 7)))
>> @@ -995,7 +998,7 @@ including psyced.")
>>                (file-name (string-append name "-" version "-checkout"))
>>                (sha256
>>                 (base32
>> -                "1viwqymbhn3cwvx0zl58rlzl5gw47zxn0ldg2nbi55ghm5zxl1z5"))))
>> +                "1m17xyixbh6wfwk727h3cfjmyfplcgvwbgh12kap1856xiqh99c5"))))
>>      (build-system gnu-build-system)
>>      (arguments
>>       `(#:tests? #f ; There are no tests/checks.
>> @@ -1034,8 +1037,7 @@ including psyced.")
>>         #:make-flags (list "install-all")))
>>      (inputs
>>       `(("zlib" ,zlib)
>> -       ("openssl" ,openssl)
>> -       ("pcre" ,pcre)))
>> +       ("openssl" ,openssl)))
>>      (native-inputs
>>       `(("pkg-config" ,pkg-config)
>>         ("bison" ,bison)
>> -- 
>> 2.11.0
>>
>>
>
> -- 
> ♥Ⓐ  ng0  | ng0.chaosnet.org
>
>
  

Patch

diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 8660915bb..2b80589f0 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -980,10 +980,13 @@  including psyced.")
     (synopsis "PSYC library in C")
     (license license:agpl3+)))
 
-;; This commit removes the historic bundled pcre and makes psyclpc reproducible.
+;; The bundled pcre and reproducible build is introduced in an commit
+;; which broke xmpp functionality with psyclpc in psyced, therefore we
+;; wait for an upstream fix in psyced and then update psyclpc again
+;; when psyced is added.
 (define-public psyclpc
-  (let* ((commit "61cf9aa81297085e5c40170fd01221c752f8deba")
-         (revision "2"))
+  (let* ((commit "27f21a3bf0d140f0d2680c695e8df229b46a814b")
+         (revision "3"))
   (package
     (name "psyclpc")
     (version (string-append "20160821-" revision "." (string-take commit 7)))
@@ -995,7 +998,7 @@  including psyced.")
               (file-name (string-append name "-" version "-checkout"))
               (sha256
                (base32
-                "1viwqymbhn3cwvx0zl58rlzl5gw47zxn0ldg2nbi55ghm5zxl1z5"))))
+                "1m17xyixbh6wfwk727h3cfjmyfplcgvwbgh12kap1856xiqh99c5"))))
     (build-system gnu-build-system)
     (arguments
      `(#:tests? #f ; There are no tests/checks.
@@ -1034,8 +1037,7 @@  including psyced.")
        #:make-flags (list "install-all")))
     (inputs
      `(("zlib" ,zlib)
-       ("openssl" ,openssl)
-       ("pcre" ,pcre)))
+       ("openssl" ,openssl)))
     (native-inputs
      `(("pkg-config" ,pkg-config)
        ("bison" ,bison)