[16/18] gnu: Add r-gplots.

Message ID 20161124165139.13740-17-rekado@elephly.net
State New
Headers

Commit Message

Ricardo Wurmus Nov. 24, 2016, 4:51 p.m. UTC
  * gnu/packages/statistics.scm (r-gplots): New variable.
---
 gnu/packages/statistics.scm | 40 ++++++++++++++++++++++++++++++++++++++++
 1 file changed, 40 insertions(+)
  

Comments

Leo Famulari Nov. 25, 2016, 4:16 a.m. UTC | #1
On Thu, Nov 24, 2016 at 05:51:37PM +0100, Ricardo Wurmus wrote:
> * gnu/packages/statistics.scm (r-gplots): New variable.

> +    (description
> +     "This package provides various R programming tools for plotting data,
> +including:
> +
> +@itemize
> +@item calculating and plotting locally smoothed summary function
> +@item enhanced versions of standard plots
> +@item manipulating colors
> +@item calculating and plotting two-dimensional data summaries
> +@item enhanced regression diagnostic plots
> +@item formula-enabled interface to @code{stats::lowess} function
> +@item displaying textual data in plots
> +@item baloon plots
> +@item plotting \"Venn\" diagrams
> +@item displaying Open-Office style plots
> +@item plotting multiple data on same region, with separate axes
> +@item plotting means and confidence intervals
> +@item spacing points in an x-y plot so they don't overlap
> +@end itemize\n")

We had been using @enumerate instead of @itemize to work around
<http://bugs.gnu.org/21772>. Do you know if Andy's fix is in our Guile
yet?
  
Ludovic Courtès Nov. 25, 2016, 10:53 p.m. UTC | #2
Leo Famulari <leo@famulari.name> skribis:

> On Thu, Nov 24, 2016 at 05:51:37PM +0100, Ricardo Wurmus wrote:
>> * gnu/packages/statistics.scm (r-gplots): New variable.
>
>> +    (description
>> +     "This package provides various R programming tools for plotting data,
>> +including:
>> +
>> +@itemize
>> +@item calculating and plotting locally smoothed summary function
>> +@item enhanced versions of standard plots
>> +@item manipulating colors
>> +@item calculating and plotting two-dimensional data summaries
>> +@item enhanced regression diagnostic plots
>> +@item formula-enabled interface to @code{stats::lowess} function
>> +@item displaying textual data in plots
>> +@item baloon plots
>> +@item plotting \"Venn\" diagrams
>> +@item displaying Open-Office style plots
>> +@item plotting multiple data on same region, with separate axes
>> +@item plotting means and confidence intervals
>> +@item spacing points in an x-y plot so they don't overlap
>> +@end itemize\n")
>
> We had been using @enumerate instead of @itemize to work around
> <http://bugs.gnu.org/21772>. Do you know if Andy's fix is in our Guile
> yet?

Yes, it’s in 2.0.12.

Ludo’.
  
Ricardo Wurmus Nov. 28, 2016, 9:47 p.m. UTC | #3
Ludovic Courtès <ludo@gnu.org> writes:

> Leo Famulari <leo@famulari.name> skribis:
>
>> On Thu, Nov 24, 2016 at 05:51:37PM +0100, Ricardo Wurmus wrote:
>>> * gnu/packages/statistics.scm (r-gplots): New variable.
>>
>>> +    (description
>>> +     "This package provides various R programming tools for plotting data,
>>> +including:
>>> +
>>> +@itemize
>>> +@item calculating and plotting locally smoothed summary function
>>> +@item enhanced versions of standard plots
>>> +@item manipulating colors
>>> +@item calculating and plotting two-dimensional data summaries
>>> +@item enhanced regression diagnostic plots
>>> +@item formula-enabled interface to @code{stats::lowess} function
>>> +@item displaying textual data in plots
>>> +@item baloon plots
>>> +@item plotting \"Venn\" diagrams
>>> +@item displaying Open-Office style plots
>>> +@item plotting multiple data on same region, with separate axes
>>> +@item plotting means and confidence intervals
>>> +@item spacing points in an x-y plot so they don't overlap
>>> +@end itemize\n")
>>
>> We had been using @enumerate instead of @itemize to work around
>> <http://bugs.gnu.org/21772>. Do you know if Andy's fix is in our Guile
>> yet?
>
> Yes, it’s in 2.0.12.

Okay, so I don’t need to change it.  Thanks for the review, Leo!  I’ve
pushed this patch series to master
(bd3be46e7fd148eef4b4ba81ee5cd4d159e9c20c).
  

Patch

diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index dc519b4..f014f16 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -3645,6 +3645,46 @@  including:
 @end itemize\n")
     (license license:gpl2+)))
 
+(define-public r-gplots
+  (package
+    (name "r-gplots")
+    (version "3.0.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "gplots" version))
+       (sha256
+        (base32
+         "02nb8n3s7c1zxq2s7ycaq2ys72y7mzirxrwj954h6gdc4x1zhg9l"))))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-catools" ,r-catools)
+       ("r-gdata" ,r-gdata)
+       ("r-gtools" ,r-gtools)
+       ("r-kernsmooth" ,r-kernsmooth)))
+    (home-page "http://cran.r-project.org/web/packages/gplots")
+    (synopsis "Various R programming tools for plotting data")
+    (description
+     "This package provides various R programming tools for plotting data,
+including:
+
+@itemize
+@item calculating and plotting locally smoothed summary function
+@item enhanced versions of standard plots
+@item manipulating colors
+@item calculating and plotting two-dimensional data summaries
+@item enhanced regression diagnostic plots
+@item formula-enabled interface to @code{stats::lowess} function
+@item displaying textual data in plots
+@item baloon plots
+@item plotting \"Venn\" diagrams
+@item displaying Open-Office style plots
+@item plotting multiple data on same region, with separate axes
+@item plotting means and confidence intervals
+@item spacing points in an x-y plot so they don't overlap
+@end itemize\n")
+    (license license:gpl2+)))
+
 (define-public r-kernsmooth
   (package
     (name "r-kernsmooth")