[1/2] gnu: Add drumkv1.

Message ID 20161119102704.3706-1-rekado@elephly.net
State New
Headers

Commit Message

Ricardo Wurmus Nov. 19, 2016, 10:27 a.m. UTC
  * gnu/packages/music.scm (drumkv1): New variable.
---
 gnu/packages/music.scm | 34 ++++++++++++++++++++++++++++++++++
 1 file changed, 34 insertions(+)
  

Comments

=?utf-8?B?5a6L5paH5q2m?= Nov. 19, 2016, 12:04 p.m. UTC | #1
Ricardo Wurmus <rekado@elephly.net> writes:

> * gnu/packages/music.scm (drumkv1): New variable.
> ---
>  gnu/packages/music.scm | 34 ++++++++++++++++++++++++++++++++++
>  1 file changed, 34 insertions(+)
>
> diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
> index 12233bf..5e882b2 100644
> --- a/gnu/packages/music.scm
> +++ b/gnu/packages/music.scm
> @@ -909,6 +909,40 @@ users to select LV2 plugins and run them with jalv.")
>  oscillators and stereo effects.")
>      (license license:gpl2+)))
>  
> +(define-public drumkv1
> +  (package
> +    (name "drumkv1")
> +    (version "0.8.0")
> +    (source (origin
> +              (method url-fetch)
> +              (uri
> +               (string-append "mirror://sourceforge/drumkv1/drumkv1/" version
> +                              "/drumkv1-" version ".tar.gz"))
> +              (sha256
> +               (base32
> +                "1n2kd468kn71yp2asmamprvblmdlvh0zd8lsh3598dwi4b7aa3ga"))))
> +    (build-system gnu-build-system)
> +    (arguments
> +     `(#:tests? #f ; There are no tests.
> +       #:configure-flags
> +       '("CXXFLAGS=-std=gnu++11")))
> +    (inputs
> +     `(("jack" ,jack-1)
> +       ("lv2" ,lv2)
> +       ("libsndfile" ,libsndfile)
> +       ("alsa-lib" ,alsa-lib)
> +       ("liblo" ,liblo)
> +       ("qtbase" ,qtbase)
> +       ("qttools" ,qttools)))
> +    (native-inputs
> +     `(("pkg-config" ,pkg-config)))

Does qttools end up in the closure?  I think it's used mainly for
building locale files or documentation.  Otherwise all look good!
  
Ricardo Wurmus Nov. 19, 2016, 4:28 p.m. UTC | #2
宋文武 <iyzsong@member.fsf.org> writes:

> Ricardo Wurmus <rekado@elephly.net> writes:
>
>> * gnu/packages/music.scm (drumkv1): New variable.
>> ---
>>  gnu/packages/music.scm | 34 ++++++++++++++++++++++++++++++++++
>>  1 file changed, 34 insertions(+)
>>
>> diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
>> index 12233bf..5e882b2 100644
>> --- a/gnu/packages/music.scm
>> +++ b/gnu/packages/music.scm
>> @@ -909,6 +909,40 @@ users to select LV2 plugins and run them with jalv.")
>>  oscillators and stereo effects.")
>>      (license license:gpl2+)))
>>  
>> +(define-public drumkv1
>> +  (package
>> +    (name "drumkv1")
>> +    (version "0.8.0")
>> +    (source (origin
>> +              (method url-fetch)
>> +              (uri
>> +               (string-append "mirror://sourceforge/drumkv1/drumkv1/" version
>> +                              "/drumkv1-" version ".tar.gz"))
>> +              (sha256
>> +               (base32
>> +                "1n2kd468kn71yp2asmamprvblmdlvh0zd8lsh3598dwi4b7aa3ga"))))
>> +    (build-system gnu-build-system)
>> +    (arguments
>> +     `(#:tests? #f ; There are no tests.
>> +       #:configure-flags
>> +       '("CXXFLAGS=-std=gnu++11")))
>> +    (inputs
>> +     `(("jack" ,jack-1)
>> +       ("lv2" ,lv2)
>> +       ("libsndfile" ,libsndfile)
>> +       ("alsa-lib" ,alsa-lib)
>> +       ("liblo" ,liblo)
>> +       ("qtbase" ,qtbase)
>> +       ("qttools" ,qttools)))
>> +    (native-inputs
>> +     `(("pkg-config" ,pkg-config)))
>
> Does qttools end up in the closure?  I think it's used mainly for
> building locale files or documentation.  Otherwise all look good!

You’re right.  I’ll move qttools to native-inputs.  Thanks for the hint.

~~
  

Patch

diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 12233bf..5e882b2 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -909,6 +909,40 @@  users to select LV2 plugins and run them with jalv.")
 oscillators and stereo effects.")
     (license license:gpl2+)))
 
+(define-public drumkv1
+  (package
+    (name "drumkv1")
+    (version "0.8.0")
+    (source (origin
+              (method url-fetch)
+              (uri
+               (string-append "mirror://sourceforge/drumkv1/drumkv1/" version
+                              "/drumkv1-" version ".tar.gz"))
+              (sha256
+               (base32
+                "1n2kd468kn71yp2asmamprvblmdlvh0zd8lsh3598dwi4b7aa3ga"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:tests? #f ; There are no tests.
+       #:configure-flags
+       '("CXXFLAGS=-std=gnu++11")))
+    (inputs
+     `(("jack" ,jack-1)
+       ("lv2" ,lv2)
+       ("libsndfile" ,libsndfile)
+       ("alsa-lib" ,alsa-lib)
+       ("liblo" ,liblo)
+       ("qtbase" ,qtbase)
+       ("qttools" ,qttools)))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
+    (home-page "http://drumkv1.sourceforge.net")
+    (synopsis "Drum-kit sampler synthesizer with stereo effects")
+    (description
+     "Drumkv1 is an old-school drum-kit sampler synthesizer with stereo
+effects.")
+    (license license:gpl2+)))
+
 (define-public amsynth
   (package
     (name "amsynth")