[07/16] gnu: Add python-nbformat.

Message ID 20161101122046.751-8-ricardo.wurmus@mdc-berlin.de
State New
Headers

Commit Message

Ricardo Wurmus Nov. 1, 2016, 12:20 p.m. UTC
  * gnu/packages/python.scm (python-nbformat, python2-nbformat): New
variables.
---
 gnu/packages/python.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)
  

Comments

Roel Janssen Nov. 1, 2016, 2:27 p.m. UTC | #1
Ricardo Wurmus writes:

> * gnu/packages/python.scm (python-nbformat, python2-nbformat): New
> variables.
> ---
>  gnu/packages/python.scm | 28 ++++++++++++++++++++++++++++
>  1 file changed, 28 insertions(+)
>
> diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
> index ed736ff..590ba43 100644
> --- a/gnu/packages/python.scm
> +++ b/gnu/packages/python.scm
> @@ -6665,6 +6665,34 @@ Debian-related files, such as:
>  (define-public python2-debian
>    (package-with-python2 python-debian))
>  
> +(define-public python-nbformat
> +  (package
> +    (name "python-nbformat")
> +    (version "4.1.0")
> +    (source
> +     (origin
> +       (method url-fetch)
> +       (uri (pypi-uri "nbformat" version))
> +       (sha256
> +        (base32
> +         "0mq8iki3d4mnx7wy05phss7x98mds4fqydin8lcagidp1knw1xnv"))))
> +    (build-system python-build-system)
> +    (arguments `(#:tests? #f)) ; no test target
> +    (propagated-inputs
> +     `(("python-ipython-genutils" ,python-ipython-genutils)
> +       ("python-jsonschema" ,python-jsonschema)
> +       ("python-jupyter-core" ,python-jupyter-core)
> +       ("python-setuptools" ,python-setuptools)
> +       ("python-traitlets" ,python-traitlets)))
> +    (home-page "http://jupyter.org")
> +    (synopsis "Jupyter Notebook format")

Notebook or notebook?

> +    (description "This package provides the reference implementation of the
> +Jupyter Notebook format and Python APIs for working with notebooks.")
> +    (license license:bsd-3)))
> +
> +(define-public python2-nbformat
> +  (package-with-python2 python-nbformat))
> +
>  (define-public python-chardet
>    (package
>      (name "python-chardet")

Otherwise LGTM!

Kind regards,
Roel Janssen
  
Hartmut Goebel Nov. 2, 2016, 8:23 a.m. UTC | #2
Am 01.11.2016 um 13:20 schrieb Ricardo Wurmus:
> +    (propagated-inputs
> +     `(("python-ipython-genutils" ,python-ipython-genutils)
> +       ("python-jsonschema" ,python-jsonschema)
> +       ("python-jupyter-core" ,python-jupyter-core)
> +       ("python-setuptools" ,python-setuptools)
Why is setuptools required at run-time?

This question also belongs to the other packages where setuptools are a
propagated-input.
  
Ricardo Wurmus Nov. 4, 2016, 10:27 a.m. UTC | #3
Roel Janssen <roel@gnu.org> writes:

> Ricardo Wurmus writes:
>
>> * gnu/packages/python.scm (python-nbformat, python2-nbformat): New
>> variables.
>> ---
>>  gnu/packages/python.scm | 28 ++++++++++++++++++++++++++++
>>  1 file changed, 28 insertions(+)
>>
>> diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
>> index ed736ff..590ba43 100644
>> --- a/gnu/packages/python.scm
>> +++ b/gnu/packages/python.scm
>> @@ -6665,6 +6665,34 @@ Debian-related files, such as:
>>  (define-public python2-debian
>>    (package-with-python2 python-debian))
>>  
>> +(define-public python-nbformat
>> +  (package
>> +    (name "python-nbformat")
>> +    (version "4.1.0")
>> +    (source
>> +     (origin
>> +       (method url-fetch)
>> +       (uri (pypi-uri "nbformat" version))
>> +       (sha256
>> +        (base32
>> +         "0mq8iki3d4mnx7wy05phss7x98mds4fqydin8lcagidp1knw1xnv"))))
>> +    (build-system python-build-system)
>> +    (arguments `(#:tests? #f)) ; no test target
>> +    (propagated-inputs
>> +     `(("python-ipython-genutils" ,python-ipython-genutils)
>> +       ("python-jsonschema" ,python-jsonschema)
>> +       ("python-jupyter-core" ,python-jupyter-core)
>> +       ("python-setuptools" ,python-setuptools)
>> +       ("python-traitlets" ,python-traitlets)))
>> +    (home-page "http://jupyter.org")
>> +    (synopsis "Jupyter Notebook format")
>
> Notebook or notebook?

Capitalised because it’s a proper name.

~~ Ricardo
  
Ricardo Wurmus Nov. 4, 2016, 10:28 a.m. UTC | #4
Hartmut Goebel <h.goebel@crazy-compilers.com> writes:

> Am 01.11.2016 um 13:20 schrieb Ricardo Wurmus:
>> +    (propagated-inputs
>> +     `(("python-ipython-genutils" ,python-ipython-genutils)
>> +       ("python-jsonschema" ,python-jsonschema)
>> +       ("python-jupyter-core" ,python-jupyter-core)
>> +       ("python-setuptools" ,python-setuptools)
> Why is setuptools required at run-time?
>
> This question also belongs to the other packages where setuptools are a
> propagated-input.

I think you’re right about this.  I’ll rebuild the packages with
setuptools as a native input.

Thanks!

~~ Ricardo
  

Patch

diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index ed736ff..590ba43 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -6665,6 +6665,34 @@  Debian-related files, such as:
 (define-public python2-debian
   (package-with-python2 python-debian))
 
+(define-public python-nbformat
+  (package
+    (name "python-nbformat")
+    (version "4.1.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "nbformat" version))
+       (sha256
+        (base32
+         "0mq8iki3d4mnx7wy05phss7x98mds4fqydin8lcagidp1knw1xnv"))))
+    (build-system python-build-system)
+    (arguments `(#:tests? #f)) ; no test target
+    (propagated-inputs
+     `(("python-ipython-genutils" ,python-ipython-genutils)
+       ("python-jsonschema" ,python-jsonschema)
+       ("python-jupyter-core" ,python-jupyter-core)
+       ("python-setuptools" ,python-setuptools)
+       ("python-traitlets" ,python-traitlets)))
+    (home-page "http://jupyter.org")
+    (synopsis "Jupyter Notebook format")
+    (description "This package provides the reference implementation of the
+Jupyter Notebook format and Python APIs for working with notebooks.")
+    (license license:bsd-3)))
+
+(define-public python2-nbformat
+  (package-with-python2 python-nbformat))
+
 (define-public python-chardet
   (package
     (name "python-chardet")