Commit Message
* gnu/packages/linux.scm (alsa-plugins): New variable.
---
gnu/packages/linux.scm | 33 +++++++++++++++++++++++++++++++++
1 file changed, 33 insertions(+)
Comments
ng0 <ng0@we.make.ritual.n0.is> writes:
> * gnu/packages/linux.scm (alsa-plugins): New variable.
> ---
> gnu/packages/linux.scm | 33 +++++++++++++++++++++++++++++++++
> 1 file changed, 33 insertions(+)
>
> diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
> index 934a67f..ea680da 100644
> --- a/gnu/packages/linux.scm
> +++ b/gnu/packages/linux.scm
> @@ -15,6 +15,7 @@
> ;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
> ;;; Copyright © 2016 David Craven <david@craven.ch>
> ;;; Copyright © 2016 John Darrington <jmd@gnu.org>
> +;;; Copyright © 2016 ng0 <ng0@we.make.ritual.n0.is>
> ;;;
> ;;; This file is part of GNU Guix.
> ;;;
> @@ -69,6 +70,8 @@
> #:use-module (gnu packages slang)
> #:use-module (gnu packages texinfo)
> #:use-module (gnu packages tls)
> + #:use-module (gnu packages video)
> + #:use-module (gnu packages xiph)
> #:use-module (gnu packages xml)
> #:use-module (guix build-system cmake)
> #:use-module (guix build-system gnu)
> @@ -867,6 +870,36 @@ MIDI functionality to the Linux-based operating system.")
> ;; GPLv2-only.
> (license license:gpl2)))
>
> +(define-public alsa-plugins
> + (package
> + (name "alsa-plugins")
> + (version "1.1.1")
> + (source (origin
> + (method url-fetch)
> + (uri (string-append "ftp://ftp.alsa-project.org/pub/plugins/"
> + name "-" version ".tar.bz2"))
> + (sha256
> + (base32
> + "1w81z5jlwqhd1l2m7qrq69lc4k9dnrg1wn52jsl2hrf3hbhd394f"))))
> + (build-system gnu-build-system)
> + (inputs
> + `(("alsa-lib" ,alsa-lib)
> + ("speex" ,speex) ; libspeexdsp resampling plugin
> + ("libsamplerate" ,libsamplerate) ; libsamplerate resampling plugin
> + ("ffmpeg" ,ffmpeg) ; libavcodec resampling plugin, a52 plugin
> + ("pulseaudio" ,pulseaudio))) ; PulseAudio plugin
> + (native-inputs
> + `(("pkg-config" ,pkg-config)))
> + (home-page "http://www.alsa-project.org/")
> + (synopsis "Utilities for the Advanced Linux Sound Architecture (ALSA)")
^__ can the commiting person change this to
Plugins for the Advanced … ?
> + (description
> + "The Advanced Linux Sound Architecture (ALSA) provides audio and
> +MIDI functionality to the Linux-based operating system. This package provides
> +additional plugins.")
> + (license (list license:gpl2+
> + ;; `rate/rate_samplerate.c': LGPL v2.1 or later.
> + license:lgpl2.1+))))
> +
> (define-public iptables
> (package
> (name "iptables")
@@ -15,6 +15,7 @@
;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2016 David Craven <david@craven.ch>
;;; Copyright © 2016 John Darrington <jmd@gnu.org>
+;;; Copyright © 2016 ng0 <ng0@we.make.ritual.n0.is>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -69,6 +70,8 @@
#:use-module (gnu packages slang)
#:use-module (gnu packages texinfo)
#:use-module (gnu packages tls)
+ #:use-module (gnu packages video)
+ #:use-module (gnu packages xiph)
#:use-module (gnu packages xml)
#:use-module (guix build-system cmake)
#:use-module (guix build-system gnu)
@@ -867,6 +870,36 @@ MIDI functionality to the Linux-based operating system.")
;; GPLv2-only.
(license license:gpl2)))
+(define-public alsa-plugins
+ (package
+ (name "alsa-plugins")
+ (version "1.1.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "ftp://ftp.alsa-project.org/pub/plugins/"
+ name "-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "1w81z5jlwqhd1l2m7qrq69lc4k9dnrg1wn52jsl2hrf3hbhd394f"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("alsa-lib" ,alsa-lib)
+ ("speex" ,speex) ; libspeexdsp resampling plugin
+ ("libsamplerate" ,libsamplerate) ; libsamplerate resampling plugin
+ ("ffmpeg" ,ffmpeg) ; libavcodec resampling plugin, a52 plugin
+ ("pulseaudio" ,pulseaudio))) ; PulseAudio plugin
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (home-page "http://www.alsa-project.org/")
+ (synopsis "Utilities for the Advanced Linux Sound Architecture (ALSA)")
+ (description
+ "The Advanced Linux Sound Architecture (ALSA) provides audio and
+MIDI functionality to the Linux-based operating system. This package provides
+additional plugins.")
+ (license (list license:gpl2+
+ ;; `rate/rate_samplerate.c': LGPL v2.1 or later.
+ license:lgpl2.1+))))
+
(define-public iptables
(package
(name "iptables")