[2/4] gnu: Add libpthread_workqueue.
Commit Message
* gnu/packages/libdispatch.scm (libpthread_workqueue): New variable.
---
gnu/packages/libdispatch.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)
@@ -62,3 +62,34 @@ native kernel facilities.")
(synopsis "kqueue(2) compatibility library")
;; event.h is bsd-2
(license (list license:expat license:bsd-2))))
+
+(define-public libpthread_workqueue
+ (package
+ (name "libpthread_workqueue")
+ (version "0.9.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/mheily/libpwq/archive/v"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0gi8l6jy5d7w3fff684qfjdj16snbc8vkf27y68w91xl5jy16xri"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'autogen
+ (lambda _
+ (zero? (system* "autoreconf" "--install" "--verbose")))))))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("autoconf" ,(autoconf-wrapper))
+ ("automake" ,automake)
+ ("libtool" ,libtool)))
+ (home-page "https://github.com/mheily/libpwq")
+ (description
+ "libpthread_workqueue is a POSIX threads workqueue library.")
+ (synopsis "Portable implementation of the pthread_workqueue API")
+ (license license:bsd-2)))