gnu: torsocks: Update to 2.2.0.
Commit Message
* gnu/packages/tor.scm (torsocks): Update to 2.2.0.
* [source]: Remove patch. Change method from 'git-fetch' to 'url-fetch'.
Remove 'file-name'.
---
gnu/packages/patches/torsocks-dns-test.patch | 18 ------------------
gnu/packages/tor.scm | 13 +++++--------
2 files changed, 5 insertions(+), 26 deletions(-)
delete mode 100644 gnu/packages/patches/torsocks-dns-test.patch
deleted file mode 100644
@@ -1,18 +0,0 @@
-Skip DNS tests that rely on the ability to look up arbitary
-host names.
-
---- torsocks/tests/test_dns.c 2015-11-10 18:30:53.955941984 +0100
-+++ torsocks/tests/test_dns.c 2015-11-10 18:31:02.199941892 +0100
-@@ -134,11 +134,8 @@ static void test_getaddrinfo(const struc
- int main(int argc, char **argv)
- {
- /* Libtap call for the number of tests planned. */
-- plan_tests(NUM_TESTS);
-+ plan_tests(1);
-
-- test_getaddrinfo(&tor_check);
-- test_gethostbyname(&tor_dir_auth1);
-- test_gethostbyaddr(&tor_dir_auth2);
- test_getaddrinfo(&tor_localhost);
-
- return 0;
@@ -73,17 +73,14 @@ applications based on the TCP protocol.")
(define-public torsocks
(package
(name "torsocks")
- (version "2.0.0")
+ (version "2.2.0")
(source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://git.torproject.org/torsocks.git")
- (commit (string-append "v" version))))
+ (method url-fetch)
+ (uri (string-append "https://people.torproject.org/~dgoulet/"
+ name "/" name "-" version ".tar.xz"))
(sha256
(base32
- "0an2q5ail9z414riyjbkjkm29504hy778j914baz2gn5hlv2cfak"))
- (file-name (string-append name "-" version "-checkout"))
- (patches (search-patches "torsocks-dns-test.patch"))))
+ "0byr9ga9w79qz4vp0m11sbmspad7fsal9wm67r4znzb7zb7cis19"))))
(build-system gnu-build-system)
(arguments
'(#:phases (modify-phases %standard-phases