gnu: dbus@1.10.12: Fix search paths.

Message ID 20161015154913.6d511acf@uwaterloo.ca
State New
Headers

Commit Message

Andy Patterson Oct. 15, 2016, 7:49 p.m. UTC
  Hello,

I noticed that since 34f9582a, dbus wasn't starting up colord or
elogind on GuixSD. The following patch aims to address that.

--
Andy


From dd248d4cc7eccba01119dfd50701f75c1ee5fec8 Mon Sep 17 00:00:00 2001
From: Andy Patterson <ajpatter@uwaterloo.ca>
Date: Sat, 15 Oct 2016 15:38:27 -0400
Subject: [PATCH] gnu: dbus@1.10.12: Fix search paths.

Add the patches from dbus' source field back into its replacement. This
ensures that the grafted dbus package can find its services on GuixSD.

* gnu/packages/glib.scm (dbus-1.10.12)[source]: Inherit from
  '(package-source dbus)'
---
 gnu/packages/glib.scm | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
  

Comments

Leo Famulari Oct. 15, 2016, 10:14 p.m. UTC | #1
On Sat, Oct 15, 2016 at 03:49:13PM -0400, Andy Patterson wrote:
> Hello,
> 
> I noticed that since 34f9582a, dbus wasn't starting up colord or
> elogind on GuixSD. The following patch aims to address that.

Mea culpa!

Thanks for catching this and sending a patch. Pushed as
fcb9b9340fd9557441bf42ca9b93a7651a5c94f9.
  

Patch

diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index e549dd7..802c809 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -139,7 +139,7 @@  shared NFS home directories.")
     (source
       (let ((version "1.10.12"))
         (origin
-          (method url-fetch)
+          (inherit (package-source dbus))
           (uri (string-append
                 "https://dbus.freedesktop.org/releases/dbus/dbus-"
                 version ".tar.gz"))