[1/5] gnu: Add python-snowballstemmer.
Commit Message
* gnu/packages/python.scm (python-snowballstemmer): New variable.
---
gnu/packages/python.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)
@@ -10990,3 +10990,27 @@ with an associated set of resolve methods that know how to fetch data.")
provide extendible implementations of common aspects of a cloud so that you can
focus on building massively scalable web applications.")
(license license:expat)))
+
+(define-public python-snowballstemmer
+ (package
+ (name "python-snowballstemmer")
+ (version "1.2.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "snowballstemmer" version))
+ (sha256
+ (base32
+ "0a0idq4y5frv7qsg2x62jd7rd272749xk4x99misf5rcifk2d7wi"))))
+ (build-system python-build-system)
+ (arguments
+ `(;; No tests exist
+ #:tests? #f))
+ (home-page
+ "https://github.com/shibukawa/snowball_py")
+ (synopsis
+ "16 stemmer algorithms (15 + Poerter English stemmer)")
+ (description
+ "This package provides 16 stemmer algorithms (15 + Poerter English
+stemmer) generated from Snowball algorithms.")
+ (license license:bsd-3)))