[1/7] gnu: ghc-streaming-commons: Remove standard packages from inputs.

Message ID 20161004134008.11821-2-rekado@elephly.net
State New
Headers

Commit Message

Ricardo Wurmus Oct. 4, 2016, 1:40 p.m. UTC
  The "directory" and "transformers" modules are part of GHC and should
not be among the inputs to avoid conflicts.

* gnu/packages/haskell.scm (ghc-streaming-commons)[inputs]: Remove
"ghc-directory" and "ghc-transformers".
---
 gnu/packages/haskell.scm | 2 --
 1 file changed, 2 deletions(-)
  

Patch

diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index cf17c4f..022cfd6 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -1170,12 +1170,10 @@  version 1.3).")
     (build-system haskell-build-system)
     (inputs
      `(("ghc-blaze-builder" ,ghc-blaze-builder)
-       ("ghc-directory" ,ghc-directory)
        ("ghc-network" ,ghc-network)
        ("ghc-random" ,ghc-random)
        ("ghc-stm" ,ghc-stm)
        ("ghc-text" ,ghc-text)
-       ("ghc-transformers" ,ghc-transformers)
        ("ghc-zlib" ,ghc-zlib)))
     (native-inputs
      `(("ghc-quickcheck" ,ghc-quickcheck)