[07/12] gnu: Add cl-ppcre.
Commit Message
* gnu/packages/lisp.scm (cl-ppcre, cl-ppcre-sbcl, cl-ppcre-ecl): New
variables.
---
gnu/packages/lisp.scm | 41 +++++++++++++++++++++++++++++++++++++++++
1 file changed, 41 insertions(+)
@@ -739,3 +739,44 @@ streams which are similar to string streams.")
(outputs '("out" "src"))
(arguments
'(#:build-in-tree "src"))))
+
+(define-public cl-ppcre
+ (package
+ (name "cl-ppcre")
+ (version "2.0.11")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/edicl/cl-ppcre/archive/v"
+ version ".tar.gz"))
+ (sha256
+ (base32 "1i7daxf0wnydb0pgwiym7qh2wy70n14lxd6dyv28sy0naa8p31gd"))
+ (file-name (string-append name "-" version ".tar.gz"))))
+ (build-system asdf-build-system/source)
+ (synopsis "Portable regular expression library for Common Lisp")
+ (description "CL-PPCRE is a portable regular expression library for Common
+Lisp, which is compatible with perl. It is pretty fast, thread-safe, and
+compatible with ANSI-compliant Common Lisp implementations.")
+ (home-page "http://weitz.de/cl-ppcre/")
+ (license license:bsd-2)))
+
+(define-public cl-ppcre-sbcl
+ (package
+ (inherit cl-ppcre)
+ (name "cl-ppcre-sbcl")
+ (build-system asdf-build-system/sbcl)
+ (inputs `(("cl-ppcre" ,cl-ppcre)
+ ("flexi-streams-sbcl" ,flexi-streams-sbcl)))
+ (arguments
+ '(#:test-only-systems '("flexi-streams")))))
+
+(define-public cl-ppcre-ecl
+ (package
+ (inherit cl-ppcre)
+ (name "cl-ppcre-ecl")
+ (build-system asdf-build-system/ecl)
+ (inputs `(("cl-ppcre" ,cl-ppcre)
+ ("flexi-streams-ecl" ,flexi-streams-ecl)))
+ (arguments
+ '(#:test-only-systems '("flexi-streams")))))