[06/12] gnu: Add flexi-streams.
Commit Message
* gnu/packages/lisp.scm (flexi-streams, flexi-streams-sbcl)
(flexi-streams-ecl): New variables.
---
gnu/packages/lisp.scm | 47 +++++++++++++++++++++++++++++++++++++++++++++++
1 file changed, 47 insertions(+)
@@ -692,3 +692,50 @@ thin compatibility layer for gray streams.")
(name "trivial-gray-streams-ecl")
(build-system asdf-build-system/ecl)
(inputs `(("trivial-gray-streams" ,trivial-gray-streams)))))
+
+(define-public flexi-streams
+ (package
+ (name "flexi-streams")
+ (version "1.0.12")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/edicl/flexi-streams/archive/v"
+ version ".tar.gz"))
+ (sha256
+ (base32 "16grnxvs7vqm5s6myf8a5s7vwblzq1kgwj8i7ahz8vwvihm9gzfi"))
+ (file-name (string-append name "-" version ".tar.gz"))))
+ (build-system asdf-build-system/source)
+ (synopsis "Implementation of virtual bivalent streams for Common Lisp")
+ (description "Flexi-streams is an implementation of \"virtual\" bivalent
+streams that can be layered atop real binary or bivalent streams and that can
+be used to read and write character data in various single- or multi-octet
+encodings which can be changed on the fly. It also supplies in-memory binary
+streams which are similar to string streams.")
+ (home-page "http://weitz.de/flexi-streams/")
+ (license license:bsd-3)))
+
+(define-public flexi-streams-sbcl
+ (package
+ (inherit flexi-streams)
+ (name "flexi-streams-sbcl")
+ (build-system asdf-build-system/sbcl)
+ (inputs `(("flexi-streams" ,flexi-streams)
+ ("trivial-gray-streams-sbcl" ,trivial-gray-streams-sbcl)))
+ (propagated-inputs '())
+ (outputs '("out" "src"))
+ (arguments
+ '(#:build-in-tree "src"))))
+
+(define-public flexi-streams-ecl
+ (package
+ (inherit flexi-streams)
+ (name "flexi-streams-ecl")
+ (build-system asdf-build-system/ecl)
+ (inputs `(("flexi-streams" ,flexi-streams)
+ ("trivial-gray-streams-ecl" ,trivial-gray-streams-ecl)))
+ (propagated-inputs '())
+ (outputs '("out" "src"))
+ (arguments
+ '(#:build-in-tree "src"))))