[05/12] gnu: Add trivial-gray-streams.
Commit Message
* gnu/packages/lisp.scm (trivial-gray-streams)
(trivial-gray-streams-sbcl, trivial-gray-streams-ecl): New variables.
---
gnu/packages/lisp.scm | 39 +++++++++++++++++++++++++++++++++++++++
1 file changed, 39 insertions(+)
@@ -653,3 +653,42 @@ support.")
(propagated-inputs '())
(arguments
'(#:test-only-systems '("fiveam")))))
+
+(define-public trivial-gray-streams
+ (let ((revision "1")
+ (commit "0483ade330508b4b2edeabdb47d16ec9437ee1cb"))
+ (package
+ (name "trivial-gray-streams")
+ (version (string-append "0.0.0-" revision "." (string-take commit 7)))
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/trivial-gray-streams/trivial-gray-streams.git")
+ (commit commit)))
+ (sha256
+ (base32 "0m3rpf2x0zmdk3nf1qfa01j6a55vj7gkwhyw78qslcgbjlgh8p4d"))
+ (file-name (string-append name "-" version "-checkout"))))
+ (build-system asdf-build-system/source)
+ (synopsis "Compatibility layer for Gray streams implementations")
+ (description "Gray streams is an interface proposed for inclusion with
+ANSI CL by David N. Gray. The proposal did not make it into ANSI CL, but most
+popular CL implementations implement it. This package provides an extremely
+thin compatibility layer for gray streams.")
+ (home-page "http://www.cliki.net/trivial-gray-streams")
+ (license license:x11))))
+
+(define-public trivial-gray-streams-sbcl
+ (package
+ (inherit trivial-gray-streams)
+ (name "trivial-gray-streams-sbcl")
+ (build-system asdf-build-system/sbcl)
+ (inputs `(("trivial-gray-streams" ,trivial-gray-streams)))))
+
+(define-public trivial-gray-streams-ecl
+ (package
+ (inherit trivial-gray-streams)
+ (name "trivial-gray-streams-ecl")
+ (build-system asdf-build-system/ecl)
+ (inputs `(("trivial-gray-streams" ,trivial-gray-streams)))))