[04/12] gnu: Add bordeaux-threads.
Commit Message
* gnu/packages/lisp.scm (bordeaux-threads, bordeaux-threads-sbcl)
(bordeaux-threads-ecl): New variables.
---
gnu/packages/lisp.scm | 45 +++++++++++++++++++++++++++++++++++++++++++++
1 file changed, 45 insertions(+)
@@ -608,3 +608,48 @@ interactive development model in mind.")
(inputs `(("fiveam" ,fiveam)
("alexandria-ecl" ,alexandria-ecl)))
(propagated-inputs '())))
+
+(define-public bordeaux-threads
+ (package
+ (name "bordeaux-threads")
+ (version "0.8.5")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/sionescu/bordeaux-threads/archive/v"
+ version ".tar.gz"))
+ (sha256
+ (base32 "10ryrcx832fwqdawb6jmknymi7wpdzhi30qzx7cbrk0cpnka71w2"))
+ (file-name (string-append name "-" version ".tar.gz"))))
+ (propagated-inputs `(("alexandria" ,alexandria)))
+ (build-system asdf-build-system/source)
+ (synopsis "Portable shared-state concurrency library for Common Lisp")
+ (description "BORDEAUX-THREADS is a proposed standard for a minimal
+MP/Threading interface. It is similar to the CLIM-SYS threading and lock
+support.")
+ (home-page "https://common-lisp.net/project/bordeaux-threads/")
+ (license license:expat)))
+
+(define-public bordeaux-threads-sbcl
+ (package
+ (inherit bordeaux-threads)
+ (name "bordeaux-threads-sbcl")
+ (build-system asdf-build-system/sbcl)
+ (inputs `(("bordeaux-threads" ,bordeaux-threads)
+ ("alexandria-sbcl" ,alexandria-sbcl)
+ ("fiveam-sbcl" ,fiveam-sbcl)))
+ (propagated-inputs '())
+ (arguments
+ '(#:test-only-systems '("fiveam")))))
+
+(define-public bordeaux-threads-ecl
+ (package
+ (inherit bordeaux-threads)
+ (name "bordeaux-threads-ecl")
+ (build-system asdf-build-system/ecl)
+ (inputs `(("bordeaux-threads" ,bordeaux-threads)
+ ("alexandria-ecl" ,alexandria-ecl)
+ ("fiveam-ecl" ,fiveam-ecl)))
+ (propagated-inputs '())
+ (arguments
+ '(#:test-only-systems '("fiveam")))))