[03/12] gnu: Add fiveam.

Message ID 20160927041532.27097-4-ajpatter@uwaterloo.ca
State New
Headers

Commit Message

Andy Patterson Sept. 27, 2016, 4:15 a.m. UTC
  * gnu/packages/lisp.scm (fiveam, fiveam-sbcl, fiveam-ecl): New
  variables.
---
 gnu/packages/lisp.scm | 40 ++++++++++++++++++++++++++++++++++++++++
 1 file changed, 40 insertions(+)
  

Comments

Ludovic Courtès Oct. 8, 2016, 12:48 p.m. UTC | #1
Andy Patterson <ajpatter@uwaterloo.ca> skribis:

> * gnu/packages/lisp.scm (fiveam, fiveam-sbcl, fiveam-ecl): New
>   variables.

LGTM.

Something that maybe wasn’t discussed is the package naming convention.
So far we usually prefix packages that provide libraries by the language
or implementation name: “python-”, “emacs-”, “guile-”, etc.  For
packages that provide standalone programs the convention is to use the
program name: “stumpwm”, “darcs”, “guix”, etc.

Perhaps we could use the “cl-” prefix for source packages, and then the
“sbcl-” and “ecl-” prefixes (instead of suffixes) for binaries?

That would make you change this patch series and I understand that may
not make you happy though.  :-)

Ludo’.
  

Patch

diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index e6e69a2..64bfc92 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -568,3 +568,43 @@  scope, and portable between implementations.")
     (name "alexandria-ecl")
     (build-system asdf-build-system/ecl)
     (inputs `(("alexandria" ,alexandria)))))
+
+(define-public fiveam
+  (package
+    (name "fiveam")
+    (version "1.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://github.com/sionescu/fiveam/archive/v"
+             version ".tar.gz"))
+       (sha256
+        (base32 "0f48pcbhqs3wwwzjl5nk57d4hcbib4l9xblxc66b8c2fhvhmhxnv"))
+       (file-name (string-append name "-" version ".tar.gz"))))
+    (propagated-inputs `(("alexandria" ,alexandria)))
+    (build-system asdf-build-system/source)
+    (synopsis "Common Lisp testing framework")
+    (description "FiveAM is a simple (as far as writing and running tests
+goes) regression testing framework.  It has been designed with Common Lisp's
+interactive development model in mind.")
+    (home-page "https://common-lisp.net/project/fiveam/")
+    (license license:bsd-3)))
+
+(define-public fiveam-sbcl
+  (package
+    (inherit fiveam)
+    (name "fiveam-sbcl")
+    (build-system asdf-build-system/sbcl)
+    (inputs `(("fiveam" ,fiveam)
+              ("alexandria-sbcl" ,alexandria-sbcl)))
+    (propagated-inputs '())))
+
+(define-public fiveam-ecl
+  (package
+    (inherit fiveam)
+    (name "fiveam-ecl")
+    (build-system asdf-build-system/ecl)
+    (inputs `(("fiveam" ,fiveam)
+              ("alexandria-ecl" ,alexandria-ecl)))
+    (propagated-inputs '())))