[21/25] gnu: Add r-gostats.
Commit Message
* gnu/packages/bioinformatics.scm (r-gostats): New variable.
---
gnu/packages/bioinformatics.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)
@@ -5271,6 +5271,36 @@ Enrichment Analysis} (GSEA).")
analysis.")
(license license:artistic2.0)))
+(define-public r-gostats
+ (package
+ (name "r-gostats")
+ (version "2.38.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "GOstats" version))
+ (sha256
+ (base32
+ "1hhw6vqr8f3g4jzq0v8f2za0r1h117j5s6av87zxs41cv7dq1wb3"))))
+ (properties `((upstream-name . "GOstats")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-annotate" ,r-annotate)
+ ("r-annotationdbi" ,r-annotationdbi)
+ ("r-annotationforge" ,r-annotationforge)
+ ("r-biobase" ,r-biobase)
+ ("r-category" ,r-category)
+ ("r-go-db" ,r-go-db)
+ ("r-graph" ,r-graph)
+ ("r-rbgl" ,r-rbgl)))
+ (home-page "http://bioconductor.org/packages/GOstats")
+ (synopsis "Tools for manipulating GO and microarrays")
+ (description
+ "This package provides a set of tools for interacting with GO and
+microarray data. A variety of basic manipulation tools for graphs, hypothesis
+testing and other simple calculations.")
+ (license license:artistic2.0)))
+
(define-public vsearch
(package
(name "vsearch")