[01/25] gnu: Add r-hwriter.

Message ID 20160921204541.3981-1-ricardo.wurmus@mdc-berlin.de
State New
Headers

Commit Message

Ricardo Wurmus Sept. 21, 2016, 8:45 p.m. UTC
  * gnu/packages/web.scm (r-hwriter): New variable.
---
 gnu/packages/web.scm | 19 +++++++++++++++++++
 1 file changed, 19 insertions(+)
  

Comments

Ludovic Courtès Sept. 24, 2016, 7:44 a.m. UTC | #1
Hello!

If you don’t get more feedback, not even from ‘guix lint’, then I guess
you can safely push the 25 patches.  :-)

At first sight, they all sound fairly straightforward.

Thanks!

Ludo’.
  
Ricardo Wurmus Sept. 26, 2016, 1:09 a.m. UTC | #2
Ludovic Courtès <ludo@gnu.org> writes:

> If you don’t get more feedback, not even from ‘guix lint’, then I guess
> you can safely push the 25 patches.  :-)

Okay, will push them soon!  “guix lint” didn’t complain and the packages
have all been in use at the MDC for a while now.

~~ Ricardo
  

Patch

diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 2c63e75..3713b24 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -3301,6 +3301,25 @@  where data can be processed either in memory, on disk, or streaming via the
 callback or connection interfaces.")
     (license l:expat)))
 
+(define-public r-hwriter
+  (package
+    (name "r-hwriter")
+    (version "1.3.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "hwriter" version))
+       (sha256
+        (base32
+         "0arjsz854rfkfqhgvpqbm9lfni97dcjs66isdsfvwfd2wz932dbb"))))
+    (build-system r-build-system)
+    (home-page "http://cran.r-project.org/web/packages/hwriter")
+    (synopsis "Output R objects in HTML format")
+    (description
+     "This package provides easy-to-use and versatile functions to output R
+objects in HTML format.")
+    (license l:lgpl2.1+)))
+
 (define-public gumbo-parser
   (package
     (name "gumbo-parser")