[27/42] gnu: Add ghc-findbin.

Message ID 20160918161022.26135-27-ng0@we.make.ritual.n0.is
State New
Headers

Commit Message

non such Sept. 18, 2016, 4:10 p.m. UTC
  * gnu/packages/haskell.scm (ghc-findbin): New variable.
---
 gnu/packages/haskell.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)
  

Comments

Leo Famulari Sept. 21, 2016, 1:12 a.m. UTC | #1
On Sun, Sep 18, 2016 at 04:10:07PM +0000, ng0 wrote:
> * gnu/packages/haskell.scm (ghc-findbin): New variable.

This package is added twice.
  
non such Sept. 21, 2016, 8:20 a.m. UTC | #2
Leo Famulari <leo@famulari.name> writes:

> On Sun, Sep 18, 2016 at 04:10:07PM +0000, ng0 wrote:
>> * gnu/packages/haskell.scm (ghc-findbin): New variable.
>
> This package is added twice.
>

Oh. Weird. Thanks for catching it.
  

Patch

diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 3e7d6c4..d6746d0 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -7062,4 +7062,28 @@  the classes @code{IArray} of immutable arrays and @code{MArray} of arrays mutabl
 within appropriate monads, as well as some instances of these classes.")
     (license license:bsd-3)))
 
+(define-public ghc-findbin
+  (package
+    (name "ghc-findbin")
+    (version "0.0.5")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://hackage.haskell.org/package/FindBin-0.0.5/"
+             "FindBin-" version ".tar.gz"))
+       (sha256
+        (base32
+         "197xvn05yysmibm1p5wzxfa256lvpbknr5d1l2ws6g40w1kpk717"))))
+    (build-system haskell-build-system)
+    (home-page
+     "http://hackage.haskell.org/package/FindBin")
+    (synopsis "Locate directory of original program")
+    (description
+     "This module locates the full directory to the running program,
+to allow the use of paths relative to it.  FindBin supports invocation
+of Haskell programs via ghci, via runhaskell/runghc, as well as compiled
+as an executable.")
+    (license license:bsd-3)))
+
 ;;; haskell.scm ends here