[6/7] gnu: Add portmidi-for-extempore.
Commit Message
* gnu/packages/music.scm (portmidi-for-extempore): New variable.
---
gnu/packages/music.scm | 17 +++++++++++++++++
1 file changed, 17 insertions(+)
Comments
On Wed, Sep 14, 2016 at 5:38 AM, Ricardo Wurmus <rekado@elephly.net> wrote:
> * gnu/packages/music.scm (portmidi-for-extempore): New variable.
> ---
> gnu/packages/music.scm | 17 +++++++++++++++++
> 1 file changed, 17 insertions(+)
>
> diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
> index f294564..c62dbbc 100644
> --- a/gnu/packages/music.scm
> +++ b/gnu/packages/music.scm
> @@ -1081,6 +1081,23 @@ projects.")
> using a system-independent interface.")
> (license license:expat)))
>
> +(define-public portmidi-for-extempore
> + (package (inherit portmidi)
> + (name "portmidi-for-extempore")
> + (version "217")
> + (source (origin
> + (method url-fetch)
> + (uri (string-append "https://github.com/extemporelang/portmidi/"
> + "archive/" version ".tar.gz"))
> + (file-name (string-append name "-" version ".tar.gz"))
> + (sha256
> + (base32
> + "0gjikwciyr8kk4y3qiv1pcq58xpgw38ql1m2gs6g0qc1s8sx4235"))))
> + (build-system cmake-build-system)
> + (arguments `(#:tests? #f)) ; no tests
> + (native-inputs '())
Remove this line. ^
> + (home-page "https://github.com/extemporelang/portmidi/")))
> +
> (define-public python-pyportmidi
> (package
> (name "python-pyportmidi")
> --
> 2.10.0
LGTM otherwise.
- Dave
Thompson, David <dthompson2@worcester.edu> writes:
> On Wed, Sep 14, 2016 at 5:38 AM, Ricardo Wurmus <rekado@elephly.net> wrote:
>> * gnu/packages/music.scm (portmidi-for-extempore): New variable.
>> ---
>> gnu/packages/music.scm | 17 +++++++++++++++++
>> 1 file changed, 17 insertions(+)
>>
>> diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
>> index f294564..c62dbbc 100644
>> --- a/gnu/packages/music.scm
>> +++ b/gnu/packages/music.scm
>> @@ -1081,6 +1081,23 @@ projects.")
>> using a system-independent interface.")
>> (license license:expat)))
>>
>> +(define-public portmidi-for-extempore
>> + (package (inherit portmidi)
>> + (name "portmidi-for-extempore")
>> + (version "217")
>> + (source (origin
>> + (method url-fetch)
>> + (uri (string-append "https://github.com/extemporelang/portmidi/"
>> + "archive/" version ".tar.gz"))
>> + (file-name (string-append name "-" version ".tar.gz"))
>> + (sha256
>> + (base32
>> + "0gjikwciyr8kk4y3qiv1pcq58xpgw38ql1m2gs6g0qc1s8sx4235"))))
>> + (build-system cmake-build-system)
>> + (arguments `(#:tests? #f)) ; no tests
>> + (native-inputs '())
>
> Remove this line. ^
This inherits from “portmidi” where “native-inputs” is set to contain
“unzip”. I’m overriding this with the empty list to drop “unzip” from
the inputs.
~~ Ricardo
@@ -1081,6 +1081,23 @@ projects.")
using a system-independent interface.")
(license license:expat)))
+(define-public portmidi-for-extempore
+ (package (inherit portmidi)
+ (name "portmidi-for-extempore")
+ (version "217")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/extemporelang/portmidi/"
+ "archive/" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0gjikwciyr8kk4y3qiv1pcq58xpgw38ql1m2gs6g0qc1s8sx4235"))))
+ (build-system cmake-build-system)
+ (arguments `(#:tests? #f)) ; no tests
+ (native-inputs '())
+ (home-page "https://github.com/extemporelang/portmidi/")))
+
(define-public python-pyportmidi
(package
(name "python-pyportmidi")