[1/7] gnu: Add nanovg-for-extempore.

Message ID 20160914093812.28422-2-rekado@elephly.net
State New
Headers

Commit Message

Ricardo Wurmus Sept. 14, 2016, 9:38 a.m. UTC
  * gnu/packages/gl.scm (nanovg-for-extempore): New variable.
---
 gnu/packages/gl.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
  

Comments

David Thompson Sept. 14, 2016, 2:23 p.m. UTC | #1
On Wed, Sep 14, 2016 at 5:38 AM, Ricardo Wurmus <rekado@elephly.net> wrote:
> * gnu/packages/gl.scm (nanovg-for-extempore): New variable.

LGTM.

- Dave
  

Patch

diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index 1aa1201..707e3d4 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -4,6 +4,7 @@ 
 ;;; Copyright © 2014, 2016 David Thompson <davet@gnu.org>
 ;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
 ;;; Copyright © 2016 ng0 <ng0@we.make.ritual.n0.is>
+;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -573,3 +574,27 @@  OpenGL.")
 desktop computers.  It provides a simple API for creating windows, contexts
 and surfaces, receiving input and events.")
     (license license:zlib)))
+
+(define-public nanovg-for-extempore
+  (package
+    (name "nanovg-for-extempore")
+    (version "0.7.1")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://github.com/extemporelang/nanovg/"
+                                  "archive/"  version ".tar.gz"))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "0ivs1sagq19xiw8jxd9f8w2b39svi0n9hrbmdvckwvqg95r8701g"))))
+    (build-system cmake-build-system)
+    (arguments `(#:tests? #f)) ; no tests included
+    (inputs
+     `(("mesa" ,mesa)))
+    (home-page "https://github.com/extemporelang/nanovg")
+    (synopsis "2D vector drawing library on top of OpenGL")
+    (description "NanoVG is small antialiased vector graphics rendering
+library for OpenGL.  It has lean API modeled after HTML5 canvas API.  It is
+aimed to be a practical and fun toolset for building scalable user interfaces
+and visualizations.")
+    (license license:zlib)))