gnu: Add r-rtsne.

Message ID 20160914073834.12180-1-rekado@elephly.net
State New
Headers

Commit Message

Ricardo Wurmus Sept. 14, 2016, 7:38 a.m. UTC
  * gnu/packages/statistics.scm (r-rtsne): New variable.
---
 gnu/packages/statistics.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)
  

Comments

Leo Famulari Sept. 14, 2016, 8:50 p.m. UTC | #1
On Wed, Sep 14, 2016 at 09:38:34AM +0200, Ricardo Wurmus wrote:
> * gnu/packages/statistics.scm (r-rtsne): New variable.

> +    (license license:bsd-3)))

Some of the files in 'src/' use a 4-clause BSD license.
  
Ricardo Wurmus Sept. 16, 2016, 3:34 p.m. UTC | #2
Leo Famulari <leo@famulari.name> writes:

> On Wed, Sep 14, 2016 at 09:38:34AM +0200, Ricardo Wurmus wrote:
>> * gnu/packages/statistics.scm (r-rtsne): New variable.
>
>> +    (license license:bsd-3)))
>
> Some of the files in 'src/' use a 4-clause BSD license.

Oh, the license in the DESCRIPTION file is incomplete then.  Thanks for
checking!  I updated this and added a comment, then pushed to master.

~~ Ricardo
  

Patch

diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index f7110ae..334c72a 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -2529,6 +2529,28 @@  for reproducibility.  Notably, convenient default methods greatly facilitate
 the way current RNG settings can be changed.")
     (license license:gpl3+)))
 
+(define-public r-rtsne
+  (package
+    (name "r-rtsne")
+    (version "0.11")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "Rtsne" version))
+       (sha256
+        (base32
+         "0zi4nxgpiv1gpdmcnqdhz5kymzp8m5xj02zpf290p1yyydl76bhy"))))
+    (properties `((upstream-name . "Rtsne")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-rcpp" ,r-rcpp)))
+    (home-page "https://github.com/jkrijthe/Rtsne")
+    (synopsis "T-distributed stochastic neighbor embedding")
+    (description
+     "This package provides an R wrapper around the fast T-distributed
+Stochastic Neighbor Embedding using a Barnes-Hut implementation.")
+    (license license:bsd-3)))
+
 (define-public r-nmf
   (package
     (name "r-nmf")