[1/2] gnu: guile-redis: Remove hard-coded Guile effective version.
Commit Message
* gnu/packages/guile.scm (guile-redis)[snippet]: Modify 'ac_subst_vars'
in 'configure', and use "@GUILE_EFFECTIVE_VERSION@" instead of "2.0" in
'Makefile.in'.
---
gnu/packages/guile.scm | 16 ++++++++++------
1 file changed, 10 insertions(+), 6 deletions(-)
Comments
Ricardo Wurmus <rekado@elephly.net> skribis:
> * gnu/packages/guile.scm (guile-redis)[snippet]: Modify 'ac_subst_vars'
> in 'configure', and use "@GUILE_EFFECTIVE_VERSION@" instead of "2.0" in
> 'Makefile.in'.
OK!
Ludovic Courtès <ludo@gnu.org> writes:
> Ricardo Wurmus <rekado@elephly.net> skribis:
>
>> * gnu/packages/guile.scm (guile-redis)[snippet]: Modify 'ac_subst_vars'
>> in 'configure', and use "@GUILE_EFFECTIVE_VERSION@" instead of "2.0" in
>> 'Makefile.in'.
>
> OK!
Pushed as ea833d301b0f4ff17dbc9403e18484a03258067e.
~~ Ricardo
@@ -935,13 +935,17 @@ above command-line parameters.")
"0vx6if6b4r3kwx64vzbs6vpc0cpcr85x11w9vkzq27gw8n7isv56"))
(modules '((guix build utils)))
(snippet
- ;; Make sure everything goes under .../site/2.0, like Guile's
+ ;; Make sure everything goes under .../site/X.Y, like Guile's
;; search paths expects.
- '(substitute* '("Makefile.in"
- "redis/Makefile.in"
- "redis/commands/Makefile.in")
- (("moddir =.*/share/guile/site" all)
- (string-append all "/2.0"))))))
+ '(begin
+ (substitute* "configure"
+ (("ac_subst_vars='")
+ "ac_subst_vars='GUILE_EFFECTIVE_VERSION\n"))
+ (substitute* '("Makefile.in"
+ "redis/Makefile.in"
+ "redis/commands/Makefile.in")
+ (("moddir =.*/share/guile/site" all)
+ (string-append all "/@GUILE_EFFECTIVE_VERSION@")))))))
(build-system gnu-build-system)
(native-inputs
`(("guile" ,guile-2.0)))