[01/16] gnu: Add python-pika.

Message ID 20160911185857.2123-2-efraim@flashner.co.il
State New
Headers

Commit Message

Efraim Flashner Sept. 11, 2016, 6:58 p.m. UTC
  * gnu/packages/python.scm (python-pika): New variable.
---
 gnu/packages/python.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
  

Comments

David Craven Sept. 11, 2016, 7:36 p.m. UTC | #1
Indentation:
+    (source
+      (origin

should be (source (origin

+    (home-page "https://pika.readthedocs.org")
+    (synopsis "Pure Python AMQP Client Library")
+    (description
+     "Pika is a pure-Python implementation of the AMQP (Advanced
Message Queuing
+Protocol) 0-9-1 protocol that tries to stay fairly independent of the
underlying
+network support library.")

should be (description "Pika ...

nitpick: move home-page between description and license
  
David Craven Sept. 11, 2016, 7:37 p.m. UTC | #2
the properties delay thing is missing, dunno if it's important
  
Efraim Flashner Sept. 12, 2016, 5:33 a.m. UTC | #3
On Sun, Sep 11, 2016 at 09:37:31PM +0200, David Craven wrote:
> the properties delay thing is missing, dunno if it's important

the properties delay is needed when the python2 variant includes the
strip-python2-variant procedure, following which just about every
package that relies on it also needs it, going up the chain.
  
Ludovic Courtès Sept. 12, 2016, 11:56 a.m. UTC | #4
Efraim Flashner <efraim@flashner.co.il> skribis:

> On Sun, Sep 11, 2016 at 09:37:31PM +0200, David Craven wrote:
>> the properties delay thing is missing, dunno if it's important
>
> the properties delay is needed when the python2 variant

More generally, it is needed whenever the python2 variant of the
package is more than just a translation of the python3 variant.

For instance, compared to python-lockfile, python2-lockfile has an
additional dependency on python2-setuptools.  The ‘python2-variant’
property allows us explicitly state the relationship between these two
packages.

HTH,
Ludo’.
  

Patch

diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 8b9273c..101e7f1 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -9199,6 +9199,31 @@  focus on event-based network programming and multiprotocol integration.")
 (define-public python2-twisted
   (package-with-python2 python-twisted))
 
+(define-public python-pika
+  (package
+    (name "python-pika")
+    (version "0.10.0")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (pypi-uri "pika" version))
+        (sha256
+         (base32
+          "0nb4h08di432lv7dy2v9kpwgk0w92f24sqc2hw2s9vwr5b8v8xvj"))))
+    (build-system python-build-system)
+    (native-inputs
+     `(("python-twisted" ,python-twisted)))
+    (home-page "https://pika.readthedocs.org")
+    (synopsis "Pure Python AMQP Client Library")
+    (description
+     "Pika is a pure-Python implementation of the AMQP (Advanced Message Queuing
+Protocol) 0-9-1 protocol that tries to stay fairly independent of the underlying
+network support library.")
+    (license license:bsd-3)))
+
+(define-public python2-pika
+  (package-with-python2 python-pika))
+
 (define-public python-ply
   (package
     (name "python-ply")