[1/2] gnu: r-htmltools: Ensure temporary files can be deleted.
Commit Message
* gnu/packages/web.scm (r-htmltools)[arguments]: Add phase
"copy-files-without-mode".
---
gnu/packages/web.scm | 14 ++++++++++++++
1 file changed, 14 insertions(+)
Comments
On Thu, Sep 08, 2016 at 02:51:04PM +0200, Ricardo Wurmus wrote:
> * gnu/packages/web.scm (r-htmltools)[arguments]: Add phase
> "copy-files-without-mode".
LGTM
@@ -3125,6 +3125,20 @@ directory.")
(base32
"0j9bf80grd6gwh7116m575pycv87c0wcwkxsz3gzzfs4aw3pxyr9"))))
(build-system r-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ ;; See https://github.com/rstudio/htmltools/pull/68
+ ;; The resource files are in the store and have mode 444. After
+ ;; copying the files R fails to remove them again because it doesn't
+ ;; have write access to them.
+ (add-after 'unpack 'copy-files-without-mode
+ (lambda _
+ (substitute* "R/html_dependency.R"
+ (("file.copy\\(from, to, " prefix)
+ (string-append prefix
+ "copy.mode = FALSE, ")))
+ #t)))))
(propagated-inputs
`(("r-digest" ,r-digest)
("r-rcpp" ,r-rcpp)))