[2/2] gnu: man-db: Patch path to iconv.
Commit Message
* gnu/packages/man.scm (man-db)[arguments]: Add phase
"patch-iconv-path".
Fixes <http://bugs.gnu.org/24373>.
---
gnu/packages/man.scm | 8 +++++++-
1 file changed, 7 insertions(+), 1 deletion(-)
@@ -79,7 +79,13 @@ a flexible and convenient way.")
(("#! /bin/sh")
(string-append "#!" (which "sh")))))
(remove file-is-directory?
- (find-files "src/tests" ".*")))))))
+ (find-files "src/tests" ".*"))))))
+ (add-after 'unpack 'patch-iconv-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "src/man.c"
+ (("\"iconv\"")
+ (string-append "\"" (which "iconv") "\"")))
+ #t)))
#:configure-flags
(let ((groff (assoc-ref %build-inputs "groff"))
(less (assoc-ref %build-inputs "less"))