[2/4] gnu: node: Add search path specification for 'NODE_PATH'.
Commit Message
* gnu/packages/node.scm (node)[native-search-paths]: New field.
---
gnu/packages/node.scm | 4 ++++
1 file changed, 4 insertions(+)
@@ -151,6 +151,10 @@ it does not buffer data, it can be interrupted at anytime.")
("procps" ,procps)
("util-linux" ,util-linux)
("which" ,which)))
+ (native-search-paths
+ (list (search-path-specification
+ (variable "NODE_PATH")
+ (files '("lib/node_modules")))))
(inputs
`(("libuv" ,libuv)
("openssl" ,tls:openssl)