Commit Message
When submitting patches that require other patches I've submitted,
should I put them together in a single patch, or keep them separate
like this?
Dylan
Comments
On Fri, Aug 12, 2016 at 06:31:29PM -0700, Dylan Jeffers wrote:
> When submitting patches that require other patches I've submitted,
> should I put them together in a single patch, or keep them separate
> like this?
For patches that depend on each other, sending them as a "patch series"
will communicate the dependencies and ensure that they apply properly.
If you've made your patches on a branch besides master, you can do:
$ git format-patch -n master
... and attach those patches to an email.
You can also use `git send-email`, which uses `git format-patch` but
will also send the patch series if you set up SMTP and configure Git to
use it.
Can you resubmit these two patches using that method? Normally I
wouldn't ask you to do that but, in this case, this patch does not apply
cleanly after having applied the patch for python-requests-oauthlib;
they both have the same leading context:
> @@ -9852,3 +9853,34 @@ etc.")
> (package
> (inherit base)
> (name "ptpython2"))))
Thanks!
From 05af66570794e80b4e8ce2447152eba251d67759 Mon Sep 17 00:00:00 2001
From: Dylan Jeffers <sapientech@openmailbox.org>
Date: Fri, 12 Aug 2016 18:26:18 -0700
Subject: [PATCH] gnu: Add python-pypump
* gnu/packages/python.scm (python-pypump, python2-pypump): New
* variables.
---
gnu/packages/python.scm | 32 ++++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)
@@ -24,6 +24,7 @@
;;; Copyright © 2016 Sou Bunnbu <iyzsong@gmail.com>
;;; Copyright © 2016 Troy Sankey <sankeytms@gmail.com>
;;; Copyright © 2016 ng0 <ng0@we.make.ritual.n0.is>
+;;; Copyright © 2016 Dylan Jeffers <sapientech@sapientech@openmailbox.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -9852,3 +9853,34 @@ etc.")
(package
(inherit base)
(name "ptpython2"))))
+
+(define-public python-pypump
+ (package
+ (name "python-pypump")
+ (version "0.6")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/xray7224/PyPump")
+ (commit "6b612a7ed3c5a9b0a0190f3999fcddb851d1900f")))
+ (file-name (string-append name "-" version))
+ (sha256
+ (base32
+ "0xy9kw54a2dasc5jig1rmllwv6y3pngbw8pvi0yx2qfpswgr5qbg"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("python-requests" ,python-requests)
+ ("python-oauthlib" ,python-oauthlib)
+ ("python-requests-oauthlib" ,python-requests-oauthlib)
+ ("python-dateutil-2" ,python-dateutil-2)))
+ (home-page "https://github.com/xray7224/PyPump")
+ (synopsis "Python Pump.io library")
+ (description "PyPump is a simple but powerful and pythonic
+way of interfacing with the pump.io API.")
+ (license gpl3+)))
+
+(define-public python2-pypump
+ (package-with-python2 python-pypump))
--
2.7.3