[4/5] gnu: gnome-icon-theme, adwaita-icon-theme: Don't install 'icon-theme.cache'.
Commit Message
* gnu/packages/gnome.scm (gnome-icon-theme)[native-inputs]: Remove 'gtk+'.
[arguments]: Set 'GTK_UPDATE_ICON_CACHE' to the path of 'true'.
(adwaita-icon-theme)[native-inputs]: Add 'gtk+:bin'.
---
gnu/packages/gnome.scm | 13 ++++++++++---
1 file changed, 10 insertions(+), 3 deletions(-)
Comments
On Sat, Aug 06, 2016 at 06:46:15PM +0800, 宋文武 wrote:
> * gnu/packages/gnome.scm (gnome-icon-theme)[native-inputs]: Remove 'gtk+'.
> [arguments]: Set 'GTK_UPDATE_ICON_CACHE' to the path of 'true'.
> (adwaita-icon-theme)[native-inputs]: Add 'gtk+:bin'.
Would this patch get rid of the icon-theme cache conflicts that most
Guix users see whenever they do `guix package`?
Leo Famulari <leo@famulari.name> writes:
> On Sat, Aug 06, 2016 at 06:46:15PM +0800, 宋文武 wrote:
>> * gnu/packages/gnome.scm (gnome-icon-theme)[native-inputs]: Remove 'gtk+'.
>> [arguments]: Set 'GTK_UPDATE_ICON_CACHE' to the path of 'true'.
>> (adwaita-icon-theme)[native-inputs]: Add 'gtk+:bin'.
>
> Would this patch get rid of the icon-theme cache conflicts that most
> Guix users see whenever they do `guix package`?
Yes, that's the plan :-)
@@ -645,9 +645,14 @@ update-desktop-database: updates the database containing a cache of MIME types
(base32
"0fjh9qmmgj34zlgxb09231ld7khys562qxbpsjlaplq2j85p57im"))))
(build-system gnu-build-system)
+ (arguments
+ '(#:configure-flags
+ ;; Don't create 'icon-theme.cache'.
+ (let* ((coreutils (assoc-ref %build-inputs "coreutils"))
+ (true (string-append coreutils "/bin/true")))
+ (list (string-append "GTK_UPDATE_ICON_CACHE=" true)))))
(native-inputs
- `(("gtk+" ,gtk+) ; for gtk-update-icon-cache
- ("icon-naming-utils" ,icon-naming-utils)
+ `(("icon-naming-utils" ,icon-naming-utils)
("intltool" ,intltool)
("pkg-config" ,pkg-config)))
(home-page "http://art.gnome.org/")
@@ -669,7 +674,9 @@ update-desktop-database: updates the database containing a cache of MIME types
name "-" version ".tar.xz"))
(sha256
(base32
- "0ddfwwqx8s63qbqimmbb015lqsab4s0rvy1j81jdsh7k95rqh2ks"))))))
+ "0ddfwwqx8s63qbqimmbb015lqsab4s0rvy1j81jdsh7k95rqh2ks"))))
+ (native-inputs
+ `(("gtk-encode-symbolic-svg" ,gtk+ "bin")))))
(define-public shared-mime-info
(package